I've been trying to use the hairnet addon in 3.0, the opinions "sheet" and "curve" work just fine, but using fibermesh, gives me this error no matter what enter image description here

Then I tried using hairnet in 2.9, thinking it was because of 3.0, I used hairnet 6.2. Then I get this new error from fibermesh enter image description here

The mesh enter image description here

and the seams enter image description here

I've tried multiple objects that would have the hair grow on them, nothing changed.

Are there other addons/resources that turns meshes into hair particles? Or is there a way to fix these errors?

  • $\begingroup$ How does your fiber mesh look like? I've just tried HairNet 0.6.6 with Blender 3.0 and it worked. $\endgroup$
    – Blunder
    Commented Jan 6, 2022 at 20:15
  • $\begingroup$ @Blunder let me give the image of the mesh, but fibermesh is doing this with any object, not just the one I'm trying to use it on $\endgroup$
    – Dark Rain
    Commented Jan 6, 2022 at 20:43

1 Answer 1


Your mesh is not a fiber. Fiber is a mesh that has only (vertical) edges that represent the hair strands. Each edge must have the same number of vertices.

Fiber example:

fiber example

You could use the Tris to Quads operation, and remove all faces and edges except the "vertical" edges. An Array modifier could add some depth.

  • $\begingroup$ Thank you for telling me, but I want to know, are there any methods or addons capable of displaying meshes like mine as hair? If not I'll use what you told me $\endgroup$
    – Dark Rain
    Commented Jan 8, 2022 at 1:04
  • $\begingroup$ The only other add-on I know is Particle Hair Guides by Lichtso (blender.stackexchange.com/a/212638/107598). It's inspired by HairNet but it looks like it can handle grid meshes (edges with vertical edges). The mesh must be a quad mesh, too. Both add-ons work very well to convert hair cards and particle hair that got converted to mesh back to particle hair. For a "hair block" they don't work. $\endgroup$
    – Blunder
    Commented Jan 8, 2022 at 3:29
  • $\begingroup$ Does it work well in 3.0? $\endgroup$
    – Dark Rain
    Commented Jan 8, 2022 at 3:52
  • $\begingroup$ Checked, it doesn't $\endgroup$
    – Dark Rain
    Commented Jan 12, 2022 at 22:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .