3
$\begingroup$

I am following through the exercises in BlenderBasics_4thEdition2011.pdf and have gotten to the section on texturing. The book goes through the creation of a Lighthouse and now I am texturing it. I want to have a closeup view of the roof of the lighthouse after partitioning it as the lesson describes on page 54.

In order to get a close up view I selected the roof and want to center the screen on the vertices of it so I pressed the Numpad . key. When I do that the view zooms so that the roof is off the screen.

What am I am doing wrong?

enter image description here

I tried Ray's answer and was able to move the origin but pressing the Numpad . key still did not work. The centering was still on the bottom of the lighthouse, as if the origin was still there.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ If you can supply the blend file that will help. Two points: 1. Just to let you know, it can be helpful to comment on an answer if it doesn't work, as that will notify the person who answered, editing a question won't. 2. Editing this question with updated details is sufficient, your other question has been marked as a duplicate of this one. $\endgroup$ – Ray Mairlot Feb 16 '15 at 1:36
  • $\begingroup$ Without more info or a .blend I don't think there is much we can do besides guess. Voted to close as unclear. Related: blender.stackexchange.com/a/3506/599 $\endgroup$ – gandalf3 Mar 18 '15 at 7:09
2
$\begingroup$

It looks like you accidentally locked the view to an object or to the 3d cursor.

To unlock the view from object:

  1. Press the N hotkey to open the properties panel on the right of the 3D view.

  2. In the View section remove the object in the Lock to Object setting. If it is active, the Object name to which the view is locked will be listed in that field.

  3. Click the X to the right of the object name to remove it.

To unlock the view from cursor:

  1. Same as above, open the properties panel scroll down to the View section.

  2. Uncheck the option "Lock to Cursor".

After unlocking the view, zooming to selection should work as expected.

In the image bellow you can see the correct settings for zooming to start working as expected. Setting for an unlocked view.

$\endgroup$
1
$\begingroup$

You can also try using Shift+b to activate the box selection zoom tool, now you can drag out a box and the view will zoom to that area.

This works in many modes, so Object, Edit, Paint, Sculpt, etc... but not the UVImage or the Node Editors.

Using Shift+c will zoom out to fit the scene so both can be used to quickly zoom in and out of an area.

That being said, if Numpad .doesn't work for you than you should try resetting Blender to Factory Defaults: 'File->Load Factory Settings'. Sometimes odd problems like the one you are having are due to some setting that was unknowingly changed.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.