2
$\begingroup$

I will be teaching a Blender class in January and I have downloaded the latest version of Blender. I am going through the BlenderBasics_4thEdition2011.pdf that I've chosen to use as a text. I'm creating a text file that is a record of my progress through that book. Now I've gotten to the camera setup procedure and I can not see a representation of a camera in my scene, so I expanded the transform menu, exposing an auxiliary panel. Atop this panel is a Scene Tree diagram that shows all of the elements in the scene. I found that you could right-click on the Camera listed there and choose the Select option that appears atop the choices. Then with the Camera selected first, I could hold down Shift and RMB on the Empty. The text says that both objects will be highlighted - though I can't verify that because I cannot see the camera. I did press Ctrl+T to add a "Track To Constraint" but the next thing the book says to do is move the camera and I can't see it to move it.

To get around the problem I started a new file and was able to move the camera that came with the standard scene. Is there a way to show the Camera Icon that I am not aware of?


Alt+H, Thanks very much!

$\endgroup$
7
  • 3
    $\begingroup$ Try Alt+H. If you accidentally press the H key with it selected, it will hide the camera in the viewport. Alt+H unhides all elements in the view. $\endgroup$
    – J Sargent
    Dec 9, 2014 at 20:09
  • 1
    $\begingroup$ Try selecting the camera from the outliner as you have done and press numpad [.] (period), this will center the view on the selection. $\endgroup$
    – PGmath
    Dec 9, 2014 at 20:34
  • 5
    $\begingroup$ The camera might be on a different layer. See Layers. $\endgroup$ Dec 9, 2014 at 22:09
  • $\begingroup$ A link to your ~.Blend file, the one with the unvisualized camera, would be most helpful. $\endgroup$
    – brasshat
    Dec 10, 2014 at 2:44
  • $\begingroup$ @NoviceInDisguise It seems that your suggestion fixed the problem, If you put that as an answer it will take this question off the “unanswered” list. Good work! $\endgroup$
    – PGmath
    Dec 10, 2014 at 14:29

2 Answers 2

3
$\begingroup$

This is a very common issue for newer Blender users. There are many hotkeys that they are not aware of, and because of that may unwittingly do something not intended. This is a prime example of that. You appear to have accidentally pressed H while your camera was selected. This keystroke is the Blender shortcut to hide objects in the viewport. To make all objects in the scene visible again, press Alt+H. This un-hides all objects in the current viewport.

$\endgroup$
0
$\begingroup$

I just ran into this, and it MAY be that Cameras added in the Sculpt layout (or others) are not immediately drawn with the usual icon. Once the user has switched to Layout, err, layout, the flag is properly set somewhere and subsequently the Camera icon is drawn correctly in all layouts. (2.80)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.