1
$\begingroup$

Calling the "view roll" command with the shortcut does not work in Object mode and Edit mode, but it works, for example, in Draw mode.

How to make the shortcut work in all modes?

enter image description here

My shortcut set up in the settings ( 3D View -> 3D View ( Global ) )

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

These custom shortcuts (Shift+1 and Shift+2) are already assigned to other operators in a few modes. If you want them to do the new function, you need to remove the old function first.

  1. Open the preferences (Edit > Preferences).
  2. Click Keymap.
  3. Switch to Key-Binding search.
  4. Type Shift 1 in the search box.
  5. Remove the Shift+1 bindings other than the one you added by pressing the x button.

Repeat the steps for the Shift+2 binding.

Bindings

As you can see in the screenshot, the shortcuts are not used in Texture Paint mode which allows your custom shortcuts to work as expected.

$\endgroup$
3
  • $\begingroup$ I removed all "Shift + 1" Shortcuts except "View Roll", but on pressing Shortcut the command still fails. Am I missing something? Image List of all Shortcuts when searching by "Shift + 1" $\endgroup$ Dec 31, 2023 at 22:24
  • $\begingroup$ I carried out the steps I listed above and added the shortcuts the same way you did, and they work for me. Do you have Emulate Numpad enabled? You can find it in the preferences under Input > Keyboard. If it's enabled, disable it, and check if that makes the shortcuts work as intended. $\endgroup$
    – Mr A
    Jan 1 at 11:31
  • $\begingroup$ I see what the problem is. When I press the combination "Shift + 1", for example, Blender for some reason executes the Hide Collection command, for which the hotkey "1" is set. Strange, why is that? Anyway, I just deactivated hotkeys "1" and "2" that activate the Hide Collection command and everything worked fine $\endgroup$ Jan 1 at 22:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .