0
$\begingroup$

So I have a shading problem I've been smashing my head against for far too long. Objects shaded smooth in Cycles have strange jagged edges at the border between lit and unlit areas

Now before you say, "oh dear, another poor fool who doesn't know _____," take a look at this screenshot:

enter image description here

This was produced via the following steps (fresh install, default settings):

  • load startup file
  • nuke default cube
  • add uv sphere
  • shade smooth
  • switch to cycles
  • enable rendered view

This issue persists across every version of Blender I've tried it on (2.9, 2.91, 2.92, and even 3.0 alpha) as well as on both CPU and GPU rendering (i7-7700k / GTX 1080). Any advice or ideas are much appreciated.

$\endgroup$
4
  • $\begingroup$ maybe you should search for compatible graphics card. for me it looks like a hardware problem on your site. I never had and i don't have that problem - on no blender version. $\endgroup$
    – Chris
    May 31, 2021 at 1:16
  • 1
    $\begingroup$ I've used this exact machine for Blender for many years with no issues and only started seeing this problem recently. Machine has an i7-7700k and GTX 1080 FWIW. $\endgroup$
    – Jordicious
    May 31, 2021 at 1:27
  • $\begingroup$ This also happens from a fresh blender download? Nothing changed? $\endgroup$
    – Chris
    May 31, 2021 at 1:36
  • $\begingroup$ This is a Cycles related problem, not a hardware issue. In Eevee you don't have this issue. $\endgroup$ May 31, 2021 at 11:18

1 Answer 1

1
$\begingroup$

This is a known problem when trying to use smooth shading on a low poly object in Cycles.

In all versions since 2.9, when using Cycles, there is an option to change the Shadow Terminator Offset in the Object Properties tab (enabled on right-side sphere). This seems to be the new way to correct this problem (previous methods involved baking a normal map from a more highly subdivided object):

Shadow

$\endgroup$
3
  • 1
    $\begingroup$ This seems to solve the issue, though it is a bit unfortunate that it makes things slightly less realistic. $\endgroup$
    – Jordicious
    May 31, 2021 at 1:51
  • $\begingroup$ Yeah., it's a bit of a trade off. Most people use it for planets, where the surrounding dark helps hide any imperfections. If extreme realism is what you're looking for, you'll probably have to subdivide the mesh a bunch more. $\endgroup$ May 31, 2021 at 2:05
  • 1
    $\begingroup$ @Jordicious "Less realistic" is a relative term here, I'd say... how realistic is it that a low-poly surface looks perfectly smooth? ;) $\endgroup$ May 31, 2021 at 11:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .