0
$\begingroup$

I am trying to render an image on Blender but a solid pink square keeps getting rendered instead. I've been trying to figure out how to fix this. It is a simple scene with only one active camera. From what I've looked up, I have view locked my camera, turned off sequencer in post processing. In the viewport shading preview, the camera displays what I want exactly. Under scene properties, the camera is selected however, everytime I press render it switches to an element like a plane in the scene instead.My camera is in the right location and pointing in the right direction.

Locked active camera

Sequencer switched off

Scene Properties

enter image description here

If anyone could help me figure this out it would be greatly appreciated!

THIS IS THE BLEND FILE. ITS FROM A POLYGON RUNWAY VIDEO I FOLLOWED :

I have attached the file because I see that there is something wrong going on when I do what Marty Fouts has suggested. However, I don't know how to fix it. As I am teaching myself to use Blender this month I have no idea what I'm doing. Thanks for everyones suggestions and help!

$\endgroup$
3
  • $\begingroup$ maybe....it would be the best if you provide your blend file, because you are a Blender beginner. Just open this blend-exchange.com and follow instructions. Before uploading do this: [1]: i.stack.imgur.com/9yQqk.png $\endgroup$
    – Chris
    May 18 at 14:53
  • $\begingroup$ Do you have multiple scenes or view layers? $\endgroup$
    – HISEROD
    May 18 at 14:57
  • $\begingroup$ Selecting the camera is not enough to make it the active camera. Select the camera and then click CTRL-NUMPAD-0. That's the 0 on the number pad, not on the main keyboard. If you don't have a number pad, you can use F3 and search for "Set Active Object as Camera". $\endgroup$ May 18 at 16:44
0
$\begingroup$

Marker Bound to an Object

Your file contains a marker in the timeline. Markers can be used to switch cameras, but if there is only one marker bound to an object, that object will be used as a camera.

The marker in your file is bound to the object "Plane.004."

Marker

You an delete a marker by hovering your cursor over it and pressing X or ⌦ Del

By deleting this marker, you will be able to change the camera to "Camera" (or any other object), and that object will remain the active camera when rendering.

It works!
btw nice render, dude!

$\endgroup$
0
$\begingroup$
  1. i would recommend to NOT lock the camera to the view, because then the camera is always changing its position whenever you move the view -> so uncheck this

  2. in the shading preview you do not see what the camera sees. You see just your selected object. This view has nothing to do with the camera.

  3. instead tap on this icon here (the most right one) -> this shows your camera view, if ...

enter image description here

  1. you tap on this camera icon

enter image description here

  1. and then this text appears: Camera perspective

enter image description here

  1. then you see a frame ...everything in this frame is your "real" camera view.

enter image description here

Happy rendering!

$\endgroup$
0
$\begingroup$

SOLVED - My issue was resolved by duplicating and deleting the objects that Blender kept replacing my active camera with. I duplicated and deleted Plane 001 and then Plane 004 and after this, I could set my camera up as the active camera and it wouldn't switch it to another object mid-render. I don't know why it was doing this in the first place though. Someone experienced would probably know.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.