2
$\begingroup$

I get a weird behavior with eevee and glass bsdf, I have a simple scene with a vertical plane with a glass-like material and a cube with an emission shader which is behind the plane from the camera point of view.

When I set the viewport shading to "rendered" I get this: rendered viewport

But when I hit render, I get that:

rendered image

The effect I want to achieve is the one I see in the viewport, but I can't get the same result in the final render, what am I missing?

You can find the blend file here: https://pasteall.org/blend/fd70eccf7c774bbc981b9040ab19f3be

$\endgroup$
0
$\begingroup$

Why do you have "Lock Camera to View" enabled? If you accidentally have moved your viewport view, then the camera view would also be different, thus changing the render. Simply disable this, and find an optimal spot for your camera, then render.

Also, I would recommend using Cycles Render engine for glass reflections, as it is more realistic.

$\endgroup$
8
  • $\begingroup$ the "lock camera to view" is on purpose, that's actually the point of view that I want for my render. The two screenshots from my question are actually the same camera with the same position. You can see for yourself with the attached blend file $\endgroup$ – soundinsekt Apr 17 at 14:32
  • $\begingroup$ If you have the point of view you want for your render, then I would probably turn the lock camera to view off, as it may be altered unintentionally. An easy way to focus the active camera to view is 'Ctrl'+'Alt'+Num0. I didn't have any problem rendering from my device. I hope this helps! $\endgroup$ – Nate_Sycro27 Apr 17 at 14:44
  • $\begingroup$ I disabled "lock camera to view" and tried rendering again but I get the same result. That's really weird that it worked for you, did you have the same result in the viewport and in the render? I just tried on another computer with another OS (linux) and a different blender version 2.82, I have the exact same problem $\endgroup$ – soundinsekt Apr 17 at 14:53
  • $\begingroup$ I had the same result in both the viewport and the render. I even added two different cameras to the scene and rendered through both views. Maybe a weird camera glitch? Try deleting and changing the camera, or maybe try Cycles. $\endgroup$ – Nate_Sycro27 Apr 17 at 15:25
  • 1
    $\begingroup$ i have exactly the same result as soundinsect. So I cannot really believe that Nate had really another result. This has nothing to do with Lock camera enabled. I disabled it right at the start.So this "answer" is in my opinion not an answer, more a question and a recommendation. $\endgroup$ – Chris Apr 17 at 23:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.