0
$\begingroup$

Following this tutorial on making a Lego-type of character but I'm having an issue where I'm trying to bake detail into an image. Specifically, I sculpted additional detail onto this hair object and now trying to bake but the resulting normal map image is always just blank. I know it isn't a problem with my UVs as I set them up previously and can paint using them just fine.

I've had this same issue before so I thought it was a bug with Blender but after updating (version 2.9 to 2.91) I'm still having the same problem.

Here are the exact steps I am doing after having finished sculpting:

  1. Create a new material and remove all previous materials from the object

  2. Create a new image at a 4K resolution (to be downsampled later) for the bake

  3. Added this image to the material as an Image Texture

  4. Go to the render tab

    4a. Switch to Cycles

    4b. Set Bake Type to Normal

  5. Ensure hair object is selected while in Object Mode

  6. Bake the image, the resulting image does in fact change but is just a blank normal map with no detail captured.

What I've already tried:

  • Adding drastic detail to the sculpt just in case my details were not being picked up, made no difference.
  • Messed with various settings in the Bake options. As a quick note, if I change the Influence-Space from Tangent to Object I DO get something in the image (which is positioned properly based on my UVs) but its certainly not what I want (not sure what this setting is even for?).

Any ideas? I'll gladly hand out my blender file too but I'm not sure where to upload it to share it.

$\endgroup$
2
  • $\begingroup$ How did you sculpt the details? Multres or high poly mesh? $\endgroup$
    – Blunder
    Jan 11 '21 at 20:51
  • $\begingroup$ @Blunder I added a multiresolution modifier to it and then sculpted. I did also apply the multires modifier after I was finished before I started baking (not sure if that was a smart move or not but it is what I did haha). Should I not have applied it? $\endgroup$ Jan 11 '21 at 22:02
0
$\begingroup$

I went back through and did everything again except this time I did not apply the multi-resolution modifier as I did before and then baked it without the multi-res option in the bake (having it checked wasn't generating properly) and it worked!

However, perhaps I have a misunderstanding of what this tool does as I'm still confused as to why having applied the modifier prevented it from working? Shouldn't the bake just bake whatever information is present? Or does it only bake based on the difference before what an object is with and without its modifiers?

$\endgroup$
1
  • $\begingroup$ No, the bake is not just baking whatever is present, the "normal" way is to to bake the multires sculpt onto the low-res UVs to add the high-res detail by a normal map. $\endgroup$ Mar 26 '21 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.