0
$\begingroup$

In the first image you can see the materials displayed in the SOLID view. T stands for a material that has a texture applied to it. W, R, Y stand for 3 materials that have no texture applied to them and only use BASE COLOR.

Now, in the second image you can see that the materials render correctly in LOOK DEV mode. They also work correctly when rendered.

Why, in the MODELING view they are colored weirdly? Where do I find that color setting?

If I didn't need to use transparency, I wouldn't care, but unluckily I'm in need of that, and transparency is not allowed in the LOOK DEV mode. If at least it was all grey.

enter image description here

enter image description here

$\endgroup$

1 Answer 1

2
$\begingroup$

Viewport display (for solid mode) and the material itself are controlled by two different settings

Take a look in MaterialProperties>ViewportDisplay on the object, it could have been mixed up

enter image description here

enter image description here

enter image description here

By the way, if on MaterialProperties>Surface the "Use Nodes" button is off, it will use Viewport Display by default

enter image description here

$\endgroup$
1
  • $\begingroup$ Oh gosh thank you! Didn't notice that section at all! $\endgroup$
    – PolyMad
    Jan 1, 2021 at 12:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .