0
$\begingroup$

As you can see from the provided picture, when I start baking fluid in this scene, the fluid flows from the wrong place and at the wrong scale (changing the size of the real inflow also changes the size of the "fake" inflow), it is also flipped in velocity direction. I have tried clearing the fluid cache as well as checking normals and surface thicknesses. No other inflow objects exists, only the collision effectors of which there are 4. Does anyone have any idea what might be causing this? I have had no issues in the past working with the new simulator and this is the first time I have run into this issue. I am happy to answer any further questions as well. Thank you!

Fluid is in wrong place

domain settings 1

domain settings 2

inflow settings

$\endgroup$
3
  • $\begingroup$ Have you tried “Apply Scale” in the domain and flow objects? $\endgroup$ Oct 9, 2020 at 20:45
  • $\begingroup$ Thank you Rich, this fixed my issue. For future reference for myself: Click on domain->Object->Apply->Scale->Free and rebake $\endgroup$
    – Parker
    Oct 9, 2020 at 21:32
  • $\begingroup$ Great - glad it helped. I've added an answer for completeness. $\endgroup$ Oct 10, 2020 at 9:39

1 Answer 1

0
$\begingroup$

The fluid simulation is sensitive to the scale of the domain mesh - if it is has been rescaled (resized in any way) you should Apply Scale to ensure the scale is set back to 1.0 in each dimension. In your case, the adjusted scale (possible negative scale) was affecting the results of the simulation.

To address this, select the Domain object and press Ctrl+A and select Scale to 'Apply Scale' (the same option is availble through Object/Apply/Scale menu). You should then Free and re-Bake your simulation if necessary - to pick up the changes.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .