0
$\begingroup$

I'm very new to Blender. I used it to create a simple water simulation successfully with a domain, collision effector, and an inflow. I'm using version 2.90.1

I've attached my blender file.

I'm trying to get Blender to run water through this tool I have. I have set one sphere(part from solidworks) as an inflow. The rest I set as collision effectors, assuming this is the correct selection to act as constraints to the water flow. I also tried Flow > Geometry.

My issue is after baking, I do not see the water flow through the model. Does my part have to be modeled in Blender to be able to apply physics to it?

The model blinks as it's running the clip, but I don't see any fluid simulated.

I read on another post to set to final resolution, but I have not been able to find this option in version 2.90.1

Thanks :)

$\endgroup$
4
+25
$\begingroup$

I would highly recommend some Fluid tutorial to start with.
Mainly to understand how domain works.


Q: Does my part have to be modeled in Blender to be able to apply physics to it?

Sure, it doesn't. For Inflow / Outlow also a Cirle object or IsoSphere with much simpler topo will works as well. Just for a 2D objects like a circle or plane enable "is Planar".

Q: The model blinks as it's running the clip, but I don't see any fluid simulated.

  • Blinking - your object has more than 2 km. In perspective mode I wasn't even able to move vertices, shading was blinking, face normals drived crazy. It's happening only in Perspective mode, workes fine in Orthogonal. I don't think it should work like that, its more like a bug.
  • Invisible simulation - your Domain dimension is more than 7.5 km with Resolution 32, so as you can see on screen - one division (represented as a cube in domain corner) is in width of your Effector - that is why no fluid is generated.

enter image description here

Just for a test - If you scale down the Domain and run Play (with Cache type Replay so you can see result without baking) tube is going to be filled by liquid.


Suggestion

I guess the object's real dimension is in centimiters (or milimetres) so I would start with scaling all down with Scale S 0.0001 to get like 20 cm and Apply Scale Ctrl+A.

Adjust Domain dimension into a rectangle necessary to cover liquid space and adjust Fluid > Settings > Resolution Division like 1024 to get enough details and let liquid get through thinner parts. Nicely summarised basics - https://blender.stackexchange.com/a/50869/2214

Note: Resolution Divisions number is a value dividing the longest edge of domain.

Test from FlipFluid - Resolution 64 enter image description here

Note: If you would like to keep the huge dimension of objects you would have to adjust Fluid - Settings - Time Scale from 1 to 10. Like now you operate in kilometers so your liquid moves slowly as giant waterfall.

League - Im not sure how exactly luquid should to flow inside the object, but you can see liquid league (penetrates) through some parts of the object. And all tricks I know to solve it failed for me for this Resolution. For Mantaflow you can try to enable Remove Air Bubles or increase Subframes. There is possible it is because of bad topology in some parts of the mesh.

Increased resolution (tested 128) solved the issue, but liquid seems to me too much detailed for that scale and calculation is too slow even for this segment.

enter image description here

Surface - blender's original fluid solver did not handle obtacles well Mantaflow has a feature Delete in Obstacle that erases all parts that goes through Collider, but surface is not following a surface yet. So I used Flip Fluid addon, that is still faster and with a three options how to solve surface arround obtacles. Check this tweet https://twitter.com/FlipFluids/status/1113907615271145480

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ if answer solved your issue consider to mark as accepted by pressing checkmark under vote arrows blender.stackexchange.com/tour $\endgroup$ – vklidu Oct 3 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.