1
$\begingroup$

I'm simulating the fluid in a pipe as shown in the image below enter image description here

I have set the inflow to -z axis and made the pipe a obstacle and also the volume initialization as shell.But still it flows outside of the pipe. enter image description here

Can some one help me resolving this issue.

ive also added the quad view with properties of inflow and domain

enter image description here

enter image description here

enter image description here

enter image description here

$\endgroup$
2
  • $\begingroup$ Show your settings as screen capture for the inflow. Use more readable view in your screen capture . In particular show your pipe thickness as a close up. Quadview is available. $\endgroup$ Mar 27 '19 at 6:32
  • $\begingroup$ Show the later stages of the fluid simulation as well. You can compose your images with free GIMP if necessary. $\endgroup$ Mar 27 '19 at 6:43
0
$\begingroup$

Some options. See which may apply to your situations.

  • I am not sure I agree with the -z setting for inflow as you currently wrote. 0 or +y seems more appropriate. Fluid will flow with gravity.

  • Make your pipe thicker or surround the spout with an outflow.

  • If the fluid is only visible coming out of the pipe use a smaller pipe spout with more thickness. One pipe for obstacle and no render. Another distinct pipe for render and not a fluid component. This may preserve more resolution.

  • Make your pipe thicker while preserving internal wall. See Fatten Shrink on the Blender Menus in edit mode.

$\endgroup$
1
  • $\begingroup$ I've updated the quad view with properties $\endgroup$
    – Ash
    Mar 27 '19 at 8:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.