2
$\begingroup$

I am trying to model a racing track, but when I add a curve, the model and I add a curve modifier to the path, it goes to a "random" position and I don't understand why! I leave here an image of the file.enter image description here

$\endgroup$
2
  • 2
    $\begingroup$ Make sure both the curve and the object have the same origin point. $\endgroup$ – Christopher Bennett Sep 4 '20 at 14:19
  • $\begingroup$ Your track section's origin is at 0,0,0 but the geometry is well offset. Try moving the track section back to the origin and rotating it back to lie perfectly aligned with one of the axes. $\endgroup$ – Ron Jensen Sep 4 '20 at 14:20
4
$\begingroup$

This is the track with the modifiers muted. Notice it is centered on the origin with location, rotation, and scale applied. Notice the length of the track is along the X axis. Its not shown, but "BezierCircle" is also centered at the origin. Modifiers muted

Here is a view with the modifiers applied. Notice the array modifier has "Fit Type" set to "FitCurve" and "BezierCircle" is selected, and "Relative Offset" is selected and set to (1,0,0) so the duplicates run along the X axis. Finally, notice the "Curve" modifier also uses the X axis as the deform axis.

Final view

$\endgroup$
1
  • $\begingroup$ Thanks! You help me a lot! $\endgroup$ – Zion albi Sep 4 '20 at 14:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.