I'm new here and I'm making a racing track for Assetto Corsa.
I don't know what's exactly happening, but something doesn't let me to apply a Curve modifier to a plane.
I'll explain myself: to make the track, first I added a Nurbs Path (Add > Curve > Path) and closed it by pressing Ctrl + F.
Here's the problem: I add a plane (to make the road), then I add a modifier of array to it to make it long as the path is, this modifier works ok, but when I add the next modifier (curve) and select the nurbs path on the object selector the plane disappears and I don't know why. Please someone help me, it's very important for me.
I leave a screenshot as well as the .blend file. If you need something else just comment; I'll be watching this question and replying very fast.

Thanks in advance! Hope someone can help me.

Up: Before adding the curve modifier. Down: After adding it.

.blend file:


2 Answers 2


Make the curve and plane have the same origin point. Apply transformations (Ctrl+A-->Rotation & Scale) in Object Mode to both objects. Subdivide the plane with loopcuts in Edit Mode (Ctrl+R). Give the plane the Curve Modifier and set the Path as a target. Choose the right deformation axis. Then go to the Curve header and check the Stretch and Bound Clamps checkboxes in a Shape panel. enter image description here

To make te plane more detailed along a curve subdivide the plane with W-->Subdivise or add more edgeloops at the start. enter image description here

EDIT: Deleted unnecessary points of your curve path and it works fine. Remember to use apply modifier while in edit mode option. It's very helpful in this case. enter image description here

Here's the .blend:

  • $\begingroup$ I've done exactly the same as sou Say, Paul and that's what I get: $\endgroup$
    – user31807
    Oct 23, 2016 at 16:57
  • $\begingroup$ postimg.org/image/vszyk12tv $\endgroup$
    – user31807
    Oct 23, 2016 at 17:00
  • $\begingroup$ Thanks for you fast reply. Hope you can help me fast as possible :) $\endgroup$
    – user31807
    Oct 23, 2016 at 17:00
  • $\begingroup$ I think there is something wrong with the path $\endgroup$
    – user31807
    Oct 23, 2016 at 17:01
  • $\begingroup$ I've checked your .blend and you're right- your curve has additional, unnecessary points. I'll try to delete them and see if it works. $\endgroup$
    – Paul Gonet
    Oct 23, 2016 at 17:25

just saw your comment. I'm answering because this morning I created an accound and just deleted the other account cause it was a temporary account and now I can't comment because I have less than 50 points of reputation... nevermind. thanks for commenting again and don't worry, we all have things to do haha I'm currently having some issues with the walls on the track. I posted a question before, take a look and better comment there so we can keep threads clean. I'll wait for your comment, thank you man and welcome back! :) Oh man, just saw a lot of people answered and I asked for it only 2 hours ago... this website is great, there is a lot of people who is ready to help you on avery case. take a look and thanks a lot, you helped me so much. walls on the track


You must log in to answer this question.