1
$\begingroup$

I am trying to make a roller coaster. I started with making a single piece of track, then added an Array Modifier, then Curve Modifier (where my curve was a simple NURBS curve).

Now, wanted to add a nice spiral to the curve, so created a separate spiral (using special curves add on), converted the spline format to Nurbs, and then merged it to my original curve (by Alt + J).

As soon as I do that, the curve modifier stops working on my rail track and the track just forms straight line (as if with only the array modifier and no curve modifier).

I tried this with simple examples and this always happens. Whenever you add a curve to your current curve, the curve modifier stops working. Any help on this please ?

Here is the file in case needed https://drive.google.com/file/d/1Mq1H64ShBL2adKhVeDP2mN5fVZcHl-4i/view?usp=sharing

$\endgroup$
  • 1
    $\begingroup$ Curve Modifier only reads the first spline segment of the curve object. Either join all segments into one continuous spline, or use separate objects $\endgroup$ – Duarte Farrajota Ramos Apr 17 '18 at 17:11
  • $\begingroup$ Also see blender.stackexchange.com/questions/65567/… for common problems with curve modifiers $\endgroup$ – Duarte Farrajota Ramos Apr 17 '18 at 17:23
  • $\begingroup$ Hmmm. I see. But in the file I attached, the big track is a continuous spline with all segments (it has the spiral part joined at the end, if you notice). However, when I try that as my Curve Modifier it does not change shape. Any suggestions on what I doing wrong ? Thank you so much for your editing and your help. [P.S. The extra piece of path hanging loose was added later for testing purposes] $\endgroup$ – Santy.8128 Apr 17 '18 at 17:24
1
$\begingroup$

The Curve Modifier only reads the first spline segment of the curve object.

Either join all segments into one continuous spline, or use separate objects for each stretch of track.

There are also a myriad of issues with your scene, one of each is unnapplied scale on the mesh. See my answer for common issues with the Curve Modifier

Besides that, the root of the problem seems to be extraneous geometry in your curves. Both of them seem to have loose vertex that unexpectedly make them multi spline curves causing unexpected behavior.

Erasing loose geometry and applying scales should solve your issues. TO easily erase all loose geometry, select one vertex of your main spline, then press Ctrl + L to select all linked vertex.

Afterwards press Ctrl + I to invert selection, effectively selecting all vertex that don't belong to the main spline, then you can erase them.

$\endgroup$
  • $\begingroup$ Let me take some time to learn all this information and try it out. I thought it might be loose vertices causing the issue, but unlike meshes W didn't work for removing doubles. I am still a beginner so don't know a lot. I will get back in case I still have questions. Thank you so much again. $\endgroup$ – Santy.8128 Apr 17 '18 at 17:57
  • $\begingroup$ Perfect that worked. Thank you so much. However, I did not understand the unapplied scale on the mesh part. I looked at the other answer as well, but didn't quite get the issue with the radius. If you get time, I would love some more information on that. Seems like that is an important thing to know about. $\endgroup$ – Santy.8128 Apr 17 '18 at 18:24
  • $\begingroup$ See blender.stackexchange.com/questions/7298/… and blender.stackexchange.com/questions/58564/… Also don't just thank in the comments, this site works best if you up vote when an answer helped you, and if it solved your problem consider marking it as accepted so it can help others in the future. $\endgroup$ – Duarte Farrajota Ramos Apr 17 '18 at 18:29
  • $\begingroup$ Yeah I know that. But since I don't have reputation on this site, my votes don't show up. $\endgroup$ – Santy.8128 Apr 17 '18 at 18:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.