1
$\begingroup$

I have 2 mesh with same material. In the slot i have 1 material (red material) applied on both mesh and curve. Why in render and view-port its showing white color

enter image description here

enter image description here

Any suggestion why its showing white material to curve.

$\endgroup$

1 Answer 1

3
$\begingroup$

You've enabled the Shadow Catcher option in the Properties panel > Object > Visibility, disable it.

enter image description here

$\endgroup$
3
  • $\begingroup$ Thanks. But if i want shadow catcher then whats the solution $\endgroup$
    – atek
    Aug 6, 2020 at 7:55
  • 3
    $\begingroup$ what do you mean, why do you want Shadow Catcher on this part, and in that case why not create a second object with Shadow Catcher? $\endgroup$
    – moonboots
    Aug 6, 2020 at 7:58
  • $\begingroup$ This sounds like a misunderstanding: Setting a part as Shadow Catcher is a trick that helps with overlaying 3D renderings onto 2D Backgrounds. Such a part does not really show in the final image itself, it only shows the shadows thrown onto it, the rest is background color. In Cycles, any material catches shadows by default (this is what the "Shadow"-toggle in the "Ray Visibility" panel above is for). So if you want a solid part with shadows, go with the defaults and get rid of the Shadow Catcher option. $\endgroup$ Aug 6, 2020 at 9:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .