0
$\begingroup$

I am watching a particular youtube video by sociamix on modelling a character base mesh. There is a part around the 9th minute where he inserts a UV sphere into the face mesh in object mode, scales and moves it perfectly into the eye socket space and then changes the face mesh back to edit mode while the UV sphere remains in object mode. I have tried several times to do it but it just doesn't seem to work for me.By it doesnt work for me i mean i try to turn the face mesh back to edit mode while leaving the uv sphere in object mode, but rather,when i click on tab to do so,they both go into edit mode,with the uv sphere being selected

https://www.youtube.com/watch?v=WlaMfIgS2ns

$\endgroup$
  • $\begingroup$ Hi. When you say "it just doesn't seem to work for me", what doesn't work for you? What happens instead? Please add more details by using the edit link below your question. Thanks. $\endgroup$ – Ray Mairlot Jun 25 at 20:29
  • $\begingroup$ In 2.8 all mesh objects selected go into edit mode. Deselect the eye before going back to edit mode with face. There is likely a way to only have active object enter edit too. $\endgroup$ – batFINGER Jun 26 at 12:33
  • $\begingroup$ what do you mean by your last statement @batFINGER $\endgroup$ – charles Jun 26 at 12:43
0
$\begingroup$

Examining this video was an interesting exercise. I was able to get this to work as he shows, but had to watch a few times. What is curious to me is that I was able to get the needed face snapping behavior without any of the checkboxes activated that he recommends in the video, which confuses me. Just to be clear, there is nothing special about the whole Object Mode/Edit Mode situation you describe. It is true, the eye is in Object Mode while the head is in Edit Mode, but the relevant point is that the video demonstrates Face Snapping while using a checkbox called Project Individual Elements. According to the tooltip, this feature allows the snapping elements to interact with other objects. So that explains how he's able to bridge the gap between Edit Mode and Object Mode. Except that it doesn't because as I said, I was able to get it to work without the Project Individual Elements option checked. So this is a mystery to me. Maybe someone else can shed some light.

I thought I would point out that I use a different technique to get eyes and eyelids to meet, and I think it's superior (if only because it requires no vertex tweaking) to the one in the video.

I start by creating a vertex group. In Object Mode, select the eyelid geometry, then go into Edit Mode and select the inner-most edge ring for the eyelid object (highlighted in green in the pic below). This vertex group will contains only the vertices from the edge ring which defines the inner rim of the eye lid.

enter image description here

Next, go to the Object Data tab, and look for the Vertex Group section. Click the "+" sign to add a new group, which will be empty initially. It will be called Group by default, but you can name it whatever you want. Click Assign.

enter image description here

Then create a Shrinkwrap modifier for the eyelid object. In Object Mode, select the eyelid object, then click on the Modifier tab in the Properties Panel and create a new modifer. Make it a Shrinkwrap.

enter image description here

Point the Shrinkwrap modifier to the eye object as its target (left green arrow), and use the Vertex Group input field to point it also to the vertex group you just created (right green arrow). If you don't use the vertex group option, the entire eyelid mesh will completely collapse against the eyeball. If you do use the vertex group option, only the inner rim will touch the eyeball. And that's exactly what you want.

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ can you explain the whole shrinkwrap modifier process more $\endgroup$ – charles Jun 26 at 12:37
  • $\begingroup$ and how do you create a vertex group $\endgroup$ – charles Jun 26 at 13:15
  • $\begingroup$ @charles I edited my above answer to address your new questions. Hope it helps. $\endgroup$ – R-800 Jun 26 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.