5
$\begingroup$

When I made changes to my model in EDIT Mode, then swap into either Pose or Object mode, or simply click off the model. My changes go away, but when I click back on the model and go into Edit mode, the changes I made are still there.

How do I make my changes visible outside of edit mode?

The object is a mesh model imported from MakeHuman as an MHX file. I have been using this file type in blender the last few days and this issue has only recently arisen, with a new file.

I am VERY new to Blender and don't know much jargon so if you can please dumb down any solutions I would be massively appreciative!

I'm not editing the weight painting, as I am in edit mode. I am editing the actual mesh, pulling and pushing vertices, sculpting etc.

$\endgroup$
  • $\begingroup$ Could you explain what you changed? I guess that the mesh you edited is weight painted and parented to a bone therefore the vertices are influenced (snap back) when you switch to object or pose mode. $\endgroup$ – stacker Sep 27 '14 at 11:50
  • $\begingroup$ confused panda, the @name only works in comments. $\endgroup$ – David Sep 27 '14 at 14:31
  • 1
    $\begingroup$ If the answer below does not match to your situation, then providing the blend file could help to understand what your issue is. You can use pasteall.org/blend and post the download link in your question. $\endgroup$ – Gaia Clary Sep 27 '14 at 14:46
  • $\begingroup$ Check, if you have accidently selected a shape key (value 0) on top of your base mesh. $\endgroup$ – user2859 Sep 27 '14 at 17:22
2
$\begingroup$

If your active Object is an armature

When you have an Armature in Edit mode, then you always see the Bones in Rest Pose. While when you switch to Pose Mode or Object mode, then you see the object in its current pose.

You can get out of this by resetting your pose to pose mode:

  • enter pose mode
  • Select all bones ( A )
  • Then type: ALT RALT SALT G to reset rotations, scales and locations of your pose bones. Or alternatively from within the 3D Viewport footer navigate to: Pose -> Clear Transform -> All

If your active Object is a Rigged Mesh

Then the object is (most probably) assigned to an Armature via the modifier Stack. In that case the Object by default gets displayed in Rest Pose when you edit the mesh. In the image below you see the object aligned to the Armature Pose when in Object mode(left side), but displayed in Rest Pose when in edit mode(right side).

enter image description here

However, you can force to display the effect of the Modifier in edit mode as well:

  • Open the Modifier Stack
  • In the Armature modifier set the options (see image)

    • Display Modifier in edit Mode
    • Adjust edit Cage to Modifier result (see note below)

      enter image description here

Note: The tool tip text is from upcoming Blender 2.72 In older Blender releases the text was: Apply modifier to editing cage during edit mode

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.