0
$\begingroup$

I wanted to try and make eyes, nose etc. for my character, so I went into edit mode and started changing the head of the mesh:

Edit mode

After making a few changes, I went back into object mode and saw this:

Object mode

I suspect it has something to do with Shape Keys, but I'm still a newbie so I'm really not sure. I had "Basis" selected in Shape Keys while making the changes, but I'm not sure that's correct. What's happening and how do I fix it? Thanks.

Edit: I was following the steps of the accepted answer of this post:

Eye socket help

Turns out it was the Knife Tool that caused my problem. I made a cut which didn't connect to a vertex, which apparently is a no-go. I still have no idea why my Shape Keys are affecting the the new vertices that I created on the face.

$\endgroup$
  • $\begingroup$ Hi Jesper I just look into your file and U have a HORRIBLE mess in the vertex groups and that makes the problems (for example in HEAD U missed some vertices on head but have another on back and hand assigned!). Try to inspect all those groups and assign correct vertices to correct groups - it solves all of your problems. $\endgroup$ – Jan Matys Oct 26 '18 at 15:07
  • $\begingroup$ ...as U could see here: pasteall.org/pic/d91f55da38960f7f46dbeeebc35878b9 ...now everything on the HEAD (others still a mess) is just fine but try it yourself as a training ;). Let me know if another prolem appears. $\endgroup$ – Jan Matys Oct 26 '18 at 15:12
  • $\begingroup$ @JanMatys Thanks for your reply. I guess that is what you get for downloading someone else's mesh. I didn't make any of the vertex groups. Anyway, I tried correcting some of them (Head, neck, chest, hips) and I don't see any effect when I go back to Object Mode. Do I have to correct every single one before I can see an effect? Also, it really confused me that editing the head as little as I did could make such a huge mess... Everything was fine before. $\endgroup$ – Jesper Oct 27 '18 at 13:11
  • $\begingroup$ @JanMatys Okay so I fixed the problem with the mesh looking all crazy. However, When I turn up the value of the Shape Keys for feet, legs, torso etc. I can see that it is affecting the vertices I have created on the face to model eyes, nose etc. How do I fix that? $\endgroup$ – Jesper Oct 27 '18 at 14:13
  • $\begingroup$ Hi Jesper please upload the file how it looks now ... will try to check it soon. $\endgroup$ – Jan Matys Oct 27 '18 at 19:40
0
$\begingroup$

If you still wish to repair the model, here is how:

Tab into edit mode and select the head key under object data (The Upside down Triangle with vertices :D).

hide all the other keys if they are not already.

your object should look normal, now toggle on and off the legs key and select the affected vertices.

Once they are all selected, delete them. (x --> vertices)

Hide every key except basis and select it. Now rebuild the faces. This is fairly easy with edge select and f.

Double check your weight painting and your all good :D

Good luck and I hope I helped,

BFB

$\endgroup$
  • $\begingroup$ Fellas dont use ANSWER as comments please next time. $\endgroup$ – Jan Matys Oct 27 '18 at 19:39
0
$\begingroup$

in object mode, the slider for the shape key becomes activated. So that you can see what your shape key does.

however make sure that you are working on the shape key that you want to change.

like for example, if you are making a change to the basis shape key. There will be no slider 0 placement..

you can delete the two shape keys if you want, by pressing the - button adjacent to the shape key list. you probably want to add them later once you have enough vertices.

I read some blender users who wrote shape keys can be added to with new vertices and still function.

I guess this sort of thing requires an extra step for visual expectations to be met.. you may have to use a function like, a "new shape key from the mix" to add the new vertices and get them to move how you want them to... I hav'nt tried this yet. My cpu buffer is really crowded so I can't do alot of extra stuff sorry.

good luck

$\endgroup$
0
$\begingroup$

Turns out it was the Knife Tool that caused one my problems. I made a cut which didn't connect to a vertex, which apparently is a no-go. After fixing this, changing the value of my shape keys still affected the new vertices that I added to the face. I solved this by adding the vertex group that I wanted to be affected by the individual shape keys to their "Blend" options.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.