0
$\begingroup$

For some strange reason, the mesh between Object and Edit mode are in completely different places. As you can see

Here, the model is aligned with the armature

enter image description here

But here, the mesh is way off.

I've applied transformations, tried to just move things back into place, reset the origins, all to no avail, and I really haven't been able to find a solution to this anywhere.

The blend file is here as requested by moonbots. Ignore any extra funkiness

$\endgroup$
3
  • $\begingroup$ did you try to select your model in object mode and press CTRL-G ? $\endgroup$
    – Chris
    Commented Mar 6, 2022 at 7:14
  • 1
    $\begingroup$ Hello could you please share your file (upload and copy paste the URL it will generate)? pasteall.org/blend $\endgroup$
    – moonboots
    Commented Mar 6, 2022 at 8:04
  • $\begingroup$ @Chris I tried that, and I'm afraid i don't really understand what it's supposed to do $\endgroup$
    – Chaitra
    Commented Mar 6, 2022 at 10:15

1 Answer 1

0
$\begingroup$

Most likely you used the armature modifier without parenting the mesh to the armature and then moved the latter. Or unparented at some point. If you check the origin of your creature, it's offset to the right and that's where your vertices jump to.
By moving the armature without having the character object following (parenting), you will deform the mesh, even though it still looks allrigt. If at all possible have the armature share its location with the object it's deforming. This way you can reset the positional offset at any time by clearing the origin of the character (eg typing 0 into xyz of the location of the child).
The origin of the armature is not visible in the screenshot, so I don't know if you can easily fix that, but you can always delete the armature modifier, reposition the armature, select the child, then the armature again and hit CTRL P -> Armature (with empty groups).

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .