0
$\begingroup$

I'm trying to make a fire simulation for an animation I'm making, but when I bake the simulation I get a strange result.

Broken_Simulation

It works completely fine in cycles,but I want to use eevee because it's a lot faster to render.

Cycles_working

There is no volumetric checkbox in blender 2.81, so I can't use that to fix my problems. I've been playing around with the settings of the simulation, but it ends the same. If anyone can help me, I'd appreciate it.

Here is my node setup (just in case).

Node_network

Here is my Smoke Domain Settings

Smoke_Domain

$\endgroup$
  • 1
    $\begingroup$ Perhaps this is a bug with respect to the Adaptive Domain settings – have you tried disabling Adaptive Domain (assuming you have it enabled)? $\endgroup$ – Christopher Gearhart Jan 12 '20 at 0:57
  • $\begingroup$ I disabled Adaptive Domain, but it still doesn't work. $\endgroup$ – Jonah McCall Jan 12 '20 at 2:07
  • 1
    $\begingroup$ Please post pictures of the Physics settings for the smoke domain, and the emitter. $\endgroup$ – user1853 Jan 12 '20 at 5:44
  • 1
    $\begingroup$ Also, with the pricipled shader you don't need a separate node for the flames i.stack.imgur.com/Draxh.png see: blender.stackexchange.com/questions/102139/… $\endgroup$ – user1853 Jan 12 '20 at 5:49
0
$\begingroup$

The issue I was running into was that I needed to use a heat attribute node. Once I added that with the flame attribute, it worked. (I also didn't separate the nodes anymore)

Node_Setup

Working_Fire

Thank you everyone who helped.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.