I'm playing with fire simulation (added it to an object via object-quick effects menu). I use couple of faces on my torch model as an emitter. I encountered a problem when the fire is rendered in front of all objects, but only in eevee. In cycles fire is rendered as I'd expect it to i.e. it doesn't overlap my torch. What should I do to fix it? I have already tried playing with parameters in physics settings and volumetric shader settings but results stay the same: good in cycles, bad in eevee. Here are 2 renders to show what I mean. First is eevee, second is cycles.

I've tried setting up fire simulation in both latest blender 2.81 and recent 2.82b eevee



1 Answer 1


This might be a little late but I figured it out. I had the same problem so after an hour of playing around with settings I figured out it's a setting under the volumetrics tab in the Scene options. Increase the start value until it doesn't go through your object.

  • $\begingroup$ Where exactly? Under Scene Properties? Or under Render Properties? $\endgroup$
    – paulrich
    Aug 26, 2021 at 2:31
  • $\begingroup$ Ah! Nevermind. I got it. It's under the Render Properties. It wasn't my Start setting under Volumetrics. It was my End. $\endgroup$
    – paulrich
    Aug 26, 2021 at 2:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .