0
$\begingroup$

I have recently purchased a package for unreal engine which contains lots of low poly models. I have some light-map issues with unreal engine. I guess that (based on the warnings within the engine) the problem is caused by the texture UV-mapping. Here is a shot of the UV map inside blender: enter image description here

And here is the 3d Model:

enter image description here

As you can see all the UVs for leaves(and other parts) are gathered in a single point, and I think that is the source of my problem. I tried to separate the vertices but its an extremely time consuming process since there are hundred of vertices and tens of models.

$\endgroup$
0
$\begingroup$

It's quite common to have 2 UV maps (or UV channels) on the same object, one for the texture maps (the one you show in your question is for the color map), and one for the lightmap.

When importing the model into UE, check the box "Generate Lightmap UV" and UE will create this second UV for you.

If you want to have more control on this map, you can create it manually into Blender :

  • In Object Data/UVMaps, hit the + button to create a New UVMap, and name it something like "Lightmap UV".
  • Make sure it is selected, then do your unwrapping as usual. Make sure no face is overlapping another, it's really important for a lightmap. The "Lightmap Pack" unwrap method give nice results (feel free to bump up the "Margin" parameter, it's quite low by default).
  • Import your model without checking "Generate Lightmap UV". Then refer to UE documentation to assign the correct UV channel to the lightmap : https://docs.unrealengine.com/en-US/Engine/Content/Types/StaticMeshes/LightmapUnwrapping/index.html
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.