0
$\begingroup$

So I'm at a loss. After baking a normal map to the low poly retopology, the end results are as seen in the posted images. The polygons are visible, and there are a large number of visual oddities. There appear to be seam-like lines all across the mesh, which I think are the polygons of the low-poly. In addition, there appears to be warping of the map around the top of the head of the mesh as seen in the first image under the horns. I don't think it's supposed to look like this is it? I appreciate any help on this problem. Thank you.

The images are as follows:

  1. Mesh with applied/baked normal map
  2. Close up of mesh with applied/baked normal map to emphasize the odd seam-like lines mentioned
  3. High Poly Mesh
  4. Low Poly Mesh Retopology

Mesh with applied normal map Close up of mesh with normal map to show seam-like lines High Poly Mesh Low Poly Mesh

Update (1): Okay, so I've messed around and clicked "smooth" for Faces, Edges, and Vertices under the Shading/UVs tab. I then checked Auto Smoothing, making the angle maxed with 180 degrees. This actually wonderfully solved the seam-like edges. But a strange effect remains across most of the mesh, it appears like a wet stain, and the .PNG of the low poly's head (with normal map baked) below elaborates the issue. It resembles ink blots.

No more Seams but the ink blotting artifact remains

Update (2): Baking process, ultimately results in weird, warped, stain-like normal map.

[Gif of my baking process[6]

Update (3):Picture of "blotty-ink" artifacting of normal map bake. This is for clarity's sake.

Blotty-ink artifacting

Update (Final): I've finally come to a close on this horrible problem. I don't know the full details of the solution, and it's still wishy-washy at best. I'm assuming that ray distance projects face normals outward. I've noticed the issues much closer to faces that are close to each other, and this is likely because the ray distance projects the normals so much that it hits the mesh itself. So, I lowered the value from 1.0 to .050. I treated the ray distance value very arbitrarily, just playing around until the UV mapping issues were at its smallest. I eventually got a cleaner uv map than before but it was still messy. But since there were only a handful of artifacts, I decided that fixing that in photoshop would be more efficient.

If anyone had a better solution that's less time-consuming/efficient, go ahead and iterate below but I have a solution that works for me for now.

$\endgroup$
2
$\begingroup$

You probably want to switch your lowpoly model to smooth shading, before baking the normal map. I also can't tell how big your texture is, but the UV map has an awful lot of wasted space.

$\endgroup$
  • $\begingroup$ I went ahead and turned on the smooth shading option under the object data tab for the low poly model. I wasn't sure if the angle was pertinent, so I set that to 30 degrees which was the default option. In addition, I'm not sure what you mean by wasted space, but I'm assuming it's because the islands aren't filling the whole of the UV map. So, I also went ahead and scaled relevant islands. So, "Auto-smooth" shading is on and the UV map's somewhat more full. However, the issue seems to persist. I'll post an image below for clarity. $\endgroup$ – Near Oct 16 '18 at 5:23
  • $\begingroup$ @Near - it's hard to tell what exactly is going on without checking all the other possibilities. You might want to upload your file to blend-exchange.giantcowfilms.com so I could take a more in-depth analysis. Please edit your original question and post the link to blend-exchange at the end of it. $\endgroup$ – metaphor_set Oct 16 '18 at 11:28
  • $\begingroup$ I've uploaded the .blend, the link is under the images of the original post as suggested. The normal map is not baked in this file in case that helps with the investigation. Thank you for your time, metaphor_set. $\endgroup$ – Near Oct 16 '18 at 23:06
  • $\begingroup$ @Near - I did a quick analysis of your mesh. There are quite a lot of problems there. Besides the auto-shading option (which you really shouldn't use for organic meshes) your lowpoly mesh is composed of tris, quads and ngons. ngons are really bad for shading. On top of that there are also lots of badly deformed polygons, which are even worse for shading, because the light doesn't know in which direction to bounce. So even if we manage to get a normal map without hard edges by using T->Tools->Shading->Smooth and baking it again, there are still lots of hard edges visible later on. $\endgroup$ – metaphor_set Oct 18 '18 at 0:43
  • $\begingroup$ I did go ahead and turn off auto-shading and use the actual smoothing option. In addition, while it wasn't the most elegant solution, I applied a subdivision modifier which made sure all existent polygons were now quads. Despite this, I still get the same "blotty" normal mapping as seen in the update .png. What is causing this problem in particular, metaphor_set? Thank you once again for looking at the mesh for these issues. $\endgroup$ – Near Oct 18 '18 at 3:22
0
$\begingroup$

Your high poly looks like it's baked to a low-poly model which didn't have its normals smoothed. So the normals are not interpolated across faces, and the baked texture is trying to compensate for that.

If your output normal map were high resolution enough your resultant bake should make your model look perfectly smooth on a low res model that didn't have smoothed normals.

However, what you want to do, in order to make things easier, is smooth the normals of your low poly model, then bake to that instead. You also need to use more of your UV space efficiently. You need to rotate parts of your unwrapped mesh and pack them as tight as you can as if you were playing tetris, so that you can fit as many pixels as possible on your texture.

If you took all of your UVs and scaled them down, even if you had a 2048 x 2048 image, you could only be taking advantage of 1024 x 1024 space if you do not optimize. Don't spend a MASSIVE amount of time on that if you have to constantly rework geometry, but still do it to some extent none the less.

$\endgroup$
  • $\begingroup$ How do I smooth normals in Blender? I did turn on auto-smooth under normals in the object data tab for 30 degrees, is that what you mean? The results are similar as seen in my second post. Should I increase the degrees for the auto-smooth if so? Let me know if I'm following that correctly, thank you, Luddens. $\endgroup$ – Near Oct 17 '18 at 1:30
  • $\begingroup$ I've found out the smoothing option and used that. This did solve one issue with the seam-like lines but the ink-blotting artifacts remain, see the update in the original post to see what I mean. Thank you. $\endgroup$ – Near Oct 17 '18 at 6:09
  • $\begingroup$ I don't know what you mean by ink blotting artificats. Can you circle them in a static image and upload those? $\endgroup$ – Jude Desir Oct 18 '18 at 23:18
  • $\begingroup$ I went ahead and did this for sake of clarity, you can see the .png at the bottom where update 3 is. Thank you for your time, Luddens. $\endgroup$ – Near Oct 19 '18 at 2:28
  • 1
    $\begingroup$ Alright! Looks like that supports my guess in part. I've actually did just that for my solution a few hours. Thanks for confirming for me, Luddens. $\endgroup$ – Near Oct 20 '18 at 0:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.