2
$\begingroup$

enter image description hereIn B2.69, with Shading Smooth & Multitexture + Matcap and 3D view selected as solid, my model looks fine while running animation.

I upgraded to 2.71 and with those same settings my model looks very blocky. I tried tweaking the edge/face/vert shading settings and everything else I could think of but got no where, the model in animation view looked really blocky like all the edges were very hard. This is not just Flat v Smooth shader, I toggled those but even in Smooth it was pretty bad.

I uninstalled and re-installed B2.69 and it's good again, so I'm dropping by to ask if this is a possible bug or some setting in the B2.71 I missed.

edit: B269 pic uploaded; Windows 7 proenter image description here

$\endgroup$
  • $\begingroup$ Can you post a screen shot also, what Operating System are you on? $\endgroup$ – GiantCowFilms Aug 1 '14 at 20:38
  • $\begingroup$ Did you tried to recalculate normals? (CTRL+N in edit mode) $\endgroup$ – Polosson Aug 2 '14 at 0:07
  • $\begingroup$ Normals are ok, recalc'd no change $\endgroup$ – govmccann Aug 2 '14 at 4:34
  • 2
    $\begingroup$ Think you need to upload the blend - could be an edge split modifier or that new Auto-smooth stuff $\endgroup$ – Greg Zaal Aug 2 '14 at 10:07
  • $\begingroup$ Yes it is probably the auto-smooth, turn it off under the object data tab and uncheck 'Auto-Smooth'. $\endgroup$ – Bert VdB Aug 3 '14 at 9:41
3
$\begingroup$

In your case this is caused by having Auto Smooth enabled.

Auto Smooth checkbox

From the wiki:

Angles on the model that are smaller than the angle specified in the Angle button will be smoothed

The Angle slider is used to control how rounded a surface may be before it is split by a hard edge. Edges with an angle greater than this value have their vertex normals split, causing it to appear as a sharp edge instead of a smooth one.

Stanford bunny with auto smoothing

From top-left to bottom-right: Auto Smooth off; On with 180 degree angle; 20 degrees; 10 degrees.

Note that Auto Smooth has no effect on flat-shaded geometry.


Another cause for this could have been the Edge Split modifier. It works similarly to Auto Smooth, except that it does not modify the vertex normals, instead it physically splits the sharp edges into two separate edges.

There is no visual difference between Auto Smooth and the Edge Split modifier, but the modifier affects the rest of the modifier stack and also may be applied.

In your case this is an undesired effect, but if you did want to use this function it's worth noting that Auto Smooth will give you much faster viewport and render performance, since the modifier is physically changing geometry and working with the rest of the stack as opposed to simply adjusting the vertex normals.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.