0
$\begingroup$

Crazy ass nobs. I get the ideal to buy a 3d printer knowing nothing about them. After a lot of searching/reading I get the thing going and feeling a little respectable until I take on this project for my girls. It's a butterfly and as you can see it's a little on the complicated side. But still, I figure out how to get it into Blender and manage to get it exported to Simplify3d and printed. The girls love it. Feeling a little smug I make the fatal mistake of suggesting that the edges would look better rounded off. Always quit when you're ahead.

So this is what I started with. ds

After a lot of hair pulling I figure out how to get the top edge selected. You'd a been laughing your butt of if you'd a seen me right clicking on one edge at a time until I learned the easy way. Anyways things were looking good until I laid the bevel on it. enter image description here Closeup of antennas. enter image description here As you can see on all the narrow areas the bevel overlaps on itself. After more searching/reading/hair pulling I discover something called "Clamp Overlap" enter image description here I didn't think it was working at first as it looks pretty much like what I started with until I zoom in. It seems to be working correctly, The antenna are so small Clamp Overlap is restricting it to a tiny size.

So I do more searching/reading/hair pulling and this time come up totally null which is why I came here lol. Does anyone know of a way to round off the corners? Like is there a mod or a secondary step I can use to get rid of the overlap without reducing the size? I've played with the modifiers in the "Object Mode" with no success but it is an option if anyone knows a trick. Even though it does the bottom also I can make it thicker to start with and then slice it in half. And if in the end the antenna and the wing tips aren't as thick as the rest it would probably be ok.

And exporting to another program would be an option. Only thing is it would probably have to be in .stl format as .obj gets it standing strait up in Simplify instead of laying flat for some reason.

Any help would be most appreciated. The wife is riding me a little about it now. :(

Edited to upload file, 2.7, already has edges selected as in picture above.

$\endgroup$
  • 6
    $\begingroup$ "God help a total nob" God doesn't usually stop by this site often. Your object has pretty awful topology. It also looks like it was converted to mesh from a curve, which would have been a much more suitable geometry type $\endgroup$ – Duarte Farrajota Ramos Jan 19 at 2:27
  • $\begingroup$ Thanks you Farrajota for replying. It's kinda English slang for a major plea for help. And you're correct, It began life as a black and white silhouette jpg which was converted to a .svg file and imported into Blender. $\endgroup$ – Que Jan 19 at 3:30
  • 4
    $\begingroup$ Please be aware that Stack Exchange is not your average run-of-the-mill forum. Ask precisely and include as much information without unnecessary fillers or "slang". Also please read this and follow the steps thoroughly to update your question by using the "edit" link below it. $\endgroup$ – metaphor_set Jan 19 at 8:55
2
$\begingroup$

Bevel will not work correctly on geometry with vertices too close to each other. Either it will overlap awfully if beveling without clamping or as you discovered there won't be any overlaps with Clamp Overlap but bevel effect will be almost invisible.

There are ways to work this around - either retopo the mesh using any of existing ways so far (manually or using any created solutions be it addons or other programs) or build bevel using curves possibilities.

enter image description here

To go with curves first selected vertices of the butterfly profile were duplicated and separated into another object (P > By Selection). Then that object was converted to curve via Alt+C in Object mode. Curve was cleaned in Edit mode afterwards - type of splines was set to Bezier, handles - to Auto so that shape is smoothed by default as much as possible.

Next step was to extrude and bevel the curve object. Easiest way is to set curve type to 2D in curve object settings, Fill option to Both and Extrude to something other than 0, depending on desired depth.

enter image description here

However if beveling intersections appear in the corners where curve handles are too near to each other due to details.

enter image description here

One way to compensate that is to decrease Offset value to the same amount as Bevel was set to, but negative. In this case Bevel was set 0.5 and the Offset to -0.5.

enter image description here

Some extra curve handles in the corners were removed and others were adjusted to get rid of remaining overlaps.

$\endgroup$
  • $\begingroup$ R El Clein It works!!!!! I can not thank you enough. $\endgroup$ – Que Jan 19 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.