I'm new to Blender and trying to achieve a bevel on my model that looks like what I have in Cinema 4D. I want just the edges to be uniformly rounded, but Blender is rounding the overall shape of the sides of the glasses. Is this possible with either the Bevel modifier or Bevel tool, or is this something else?

Blender Bevel modifier

Cinema 4D Bevel


  • 1
    $\begingroup$ Can you share? (blend-exchange.com) I can't reproduce this.. could be object-level scaling / a large bevel with Clamp Overlap.. quite a few possibilities. $\endgroup$
    – Robin Betts
    Jul 4, 2022 at 18:05
  • $\begingroup$ Do you mean that Blender is the first picture and c4d the second one and you'd like to have the same result as picture 2? How does your object look like before the bevel? As Robin says, please share your file $\endgroup$
    – moonboots
    Jul 4, 2022 at 18:07
  • $\begingroup$ Hi @RobinBetts, here's the project: <img src="https://blend-exchange.com/embedImage.png?bid=pDq5Poj6" /> $\endgroup$
    – kariomart
    Jul 4, 2022 at 18:16
  • $\begingroup$ Hi @moonboots, yes, Blender is 1st image, C4D is 2nd and what I'm trying to achieve. I've also included a 3rd image of the original model and there's a link to the project in my previous comment. $\endgroup$
    – kariomart
    Jul 4, 2022 at 18:20

1 Answer 1


The bevel modifier doesn't work since the scale is not applied on your object...

Apply the scale by pressing Ctrl + A > Scale, and then the bevel will work perfectly in Blender also.

enter image description here

Also, enable Harden Normals in the shading tab under the bevel modifier, it helps in the object's shading.

  • $\begingroup$ Thank you @yousuf-chaudhry! $\endgroup$
    – kariomart
    Jul 4, 2022 at 18:55
  • $\begingroup$ @kariomart If it solved your problem, kindly consider accepting it by clicking on the checkbox on the top left :) $\endgroup$ Jul 4, 2022 at 18:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .