2
$\begingroup$

I'm new to Blender fluid simulation and want to fill a cylinder with water.

As you can see in the following image, it fills up the cylinder, but on the rendering result, there are strange black stripes.

I tried to increase the fluid resolution to 300, but it didn't resolve this issue.

Initial attempt

The skyblue background is composed of 3 planes. I thought open space in other three axis could be a cause, so I put that cylinder in a cube, so that it resides in a closed area.

2nd attempt

Unfortunately, it didn't solve the problem neither.

Does anyone have an idea what causes this problem? I would really appreciate your help.

$\endgroup$
2
$\begingroup$

Your container is not properly scaled: enter image description here

CTRL + A with your Container object selected, then apply Scale: no more black stripes. enter image description here

Please note: in the image below I turned off object FluidDomaain for more clarity.

enter image description here

Sorry for poor english

$\endgroup$
  • $\begingroup$ Thank you for your valuable tip, but it didn't resolve the issue. With 'FluidDomain', the stripes are still there. imgur.com/fJrkXNM And your English is okay :D $\endgroup$ – dalbom Dec 7 '17 at 16:40
  • $\begingroup$ I prevented 'InitialWater' and 'FluidDomain' to be rendered and it shows clear glass bottle now. While I can turn off 'InitialWater', 'FluidDomain' is quite important for me. It seems like those two materials are interfering... $\endgroup$ – dalbom Dec 7 '17 at 16:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.