2
$\begingroup$

I'm using Glass nodes from Blender Gurus tutorial but for some reason I get this strange sphere in all my glass surfaces. If I Enable Backface Culling in material settings, the sphere disappears from Viewport reflections but still shows in final renders.

Here is the node setup and a screenshot of the artifact:

enter image description here

enter image description here

How can I get rid of it?

$\endgroup$
6
  • $\begingroup$ which tutorial? $\endgroup$
    – ETHAN DAY
    Apr 19 '21 at 20:03
  • $\begingroup$ @ETHANDAY youtu.be/KyXRBu7gn2o?t=300 $\endgroup$
    – lauriinc
    Apr 19 '21 at 20:05
  • 2
    $\begingroup$ It's a result of the insanely high Fresnel value he uses for this "hack". Change the Fresnel and you'll see the sphere change size. $\endgroup$ Apr 19 '21 at 20:18
  • $\begingroup$ Hmm okay.. But when I change the Fresnel to small it's not transparent anymore as all I get is reflections. I guess I need to find a new glass material :) $\endgroup$
    – lauriinc
    Apr 19 '21 at 20:23
  • $\begingroup$ Yeah. Keep in mind he uses this for a very special-use case. If your scene doesn't need it, there are other options. $\endgroup$ Apr 19 '21 at 20:31
1
$\begingroup$

As Christopher suggested in the comments, this glass hack has too high Fresnel value that is causing the issue. I'll use a different glass node setup.

$\endgroup$
1
$\begingroup$

I recommend a simplified setup:

enter image description here

You can use the Value of the Transparent BSDF to control the amount of shadow.

enter image description here

I have a more in-depth answer to this question that may help as well.

$\endgroup$
1
  • $\begingroup$ Thanks Allen, I actually ended up with the same nodes and it seems to work great! The only thing I could not achieve with this new setup is to make it transparent and reflective in Viewport Shading mode as I was able to do it with the previous setup above. Any suggestions on this? I work a lot in the Shading mode and not seeing anything through the windows makes it hard to work on scenes. $\endgroup$
    – lauriinc
    Apr 20 '21 at 7:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.