1
$\begingroup$

I have made mist in my scene,and it works great when it's white mist, but if I try to darken the color, I get all sorts of strange colors appearing in the background of my scene. How do I make the strange colors disappear?

Render Layers > Map Value, Render Layers > Mix, Map Value > Mix > Composite

My node setup


Withough Mist

My scene without mist


White mist

Light Mist


Dark mist with weird colors

Dark mist makes weird colors appear in the background

$\endgroup$
  • 1
    $\begingroup$ Shot in the dark: try enabling the "clamp" checkbox on the mix node. Does that fix it? $\endgroup$ – JtheNinja Jun 23 '17 at 23:03
  • $\begingroup$ @JtheNinja Thanks for your tip. It didn't fix it, but it ended up leading me to the correct solution. $\endgroup$ – That One Actor Jun 23 '17 at 23:58
1
$\begingroup$

The Mix shader needs to be changed to an Add shader.

enter image description here

I don't know exactly how these each work, but depending on what color you want your mist to be, different mixing methods work better.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.