0
$\begingroup$

I have colored my model in Vertex Paint mode, but it loses all coloring once I switch to Render. How do I go about making the color show up when I render it?

$\endgroup$
  • $\begingroup$ please share screenshots and .blend file $\endgroup$ – Tak Jan 26 '17 at 0:05
  • $\begingroup$ how do you guys usually do that? $\endgroup$ – That One Actor Jan 26 '17 at 0:05
  • $\begingroup$ blend-exchange.giantcowfilms.com then provide the link under "share this file" $\endgroup$ – Tak Jan 26 '17 at 0:06
  • $\begingroup$ This is a really general question. I have multiple models where this problem exists. $\endgroup$ – That One Actor Jan 30 '17 at 17:47
2
$\begingroup$

Let's say this is the object you have: Vertex Paint

Now open up the node editor: Node Editor

Add the material then, in the node editor add the Attribute node: Attribute Node

Change the attribute label to Col: Col Attribute

Then it will show up in both the material view: Material View

And the Render View: Render View

Hope this helps


Regards Grimlock

$\endgroup$
  • $\begingroup$ I looked at what you said, but I don't have nearly as many options in the Node editor as you do, do you have some add-ons installed that I need? $\endgroup$ – That One Actor Jan 28 '17 at 19:52
  • $\begingroup$ No, but if you go to the node editor press shift+A and hit enter on search. Type in Attribute and u should find the attribute node $\endgroup$ – Grimlock Jan 29 '17 at 22:15
  • 2
    $\begingroup$ The above is correct for using Cycles renderer, and the solution below that was accepted is correct for Blender Render material. $\endgroup$ – Craig D Jones Jan 30 '17 at 18:21
  • $\begingroup$ @Craig D Jones Thank you for your clarification $\endgroup$ – That One Actor Jan 30 '17 at 20:57
0
$\begingroup$

In object mode select the object that you would like to color, then add a material to that object. In the materials options panel, scroll down until you reach the Vertex Color Paint checkbox.

Once you check that, then all the color you add in the Vertex Pain mode will be rendered.

Blender v2.76

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.