1
$\begingroup$

I am using Blender 2.69, (I am unable to upgrade at this time) and I am trying to color my model using the Vertex Paint mode, but it won't show up in the final render. I know that you have to enable something in the options pane to the left, but the option that all the guides talk about is not there. Am I in the wrong mode? Can someone help me with this? I also tried texture paint mode, but then I can't actually paint anything it seems. Any suggestions?

$\endgroup$
  • 1
    $\begingroup$ Welcome to the site :) What render engine are you using? There should be a drop down at the top of the screen which says something like "Blender Render" or "Cycles". Depending on what its set to, the way vertex colors are setup varies quite a bit. Also, on this site we prefer to have a limit of one question per post. This helps keep things organized and easier to find for other users/people searching on google. Feel free to ask as many questions in separate posts as you like :) $\endgroup$ – gandalf3 Dec 8 '14 at 6:22
  • $\begingroup$ Have you tried updating to 2.72? Also if you want something to show up in the render, use texture paint. $\endgroup$ – Scalia Dec 8 '14 at 19:22
  • $\begingroup$ Thank you both for the suggestions. You can disregard the other questions I asked in the post besides the first one, I found an answer. But I still can't get colors to show up in the. It is set to Blender Render, and using texture paint, nothing happens. $\endgroup$ – Republican31 Dec 8 '14 at 21:33
  • $\begingroup$ @Republican31 You must first UV unwrap your mesh and add a texture. If you've done that, is it possible you could add your .blend file? This would make it easier for us to tell exactly what is wrong.. $\endgroup$ – gandalf3 Dec 8 '14 at 21:40
  • $\begingroup$ Thank all for your help! But I actually found out on my own what the little problem was. I couldn't find the option to set colors and paint to show up in the render, but now I know that it is in the material option on the right panel. Do I need to put this in as an answer, or just edit the name of the thread as "[SOVED] or anything like that? $\endgroup$ – Republican31 Dec 10 '14 at 3:35
6
$\begingroup$

Weight Painting, Texture Painting and Vertex Painting are all completely different.

Weight painting directly modifies vertex groups, which can be used to designate areas of an object (such as where you want hair to grow).

Vertex painting allows you to color the individual vertices. This technically could work, however if you have a low-poly model it's going to look pretty bad. Additionally, as far as I'm aware, vertex painting is not compatible with Cycles. PGMath points out that it is possible with Attribute nodes.

Texture painting is what you want.

enter image description here

Exhibit A: Our model

Step 1: UV Unwrap Your Model

If you have already done this, or already know how, go ahead and skip this step.

Basically you want to go into edit mode and select a bunch of vertices so that if you took scissors and cut along the selected lines, you'd end up with a bunch of more or less flat objects. Like so:

enter image description here

Now press CTRL + E and click Mark Seam.

enter image description here

Press A twice so that every vertex is selected, and then press U and click Unwrap.

enter image description here

Great! You're done with this step.

Step 2: Setting up the texture

If you have already done this, or know how, you can skip this step too.

First you need to create a texture for your model. Making sure your model is selected, and that it has a material, go to the texture panel and click + New.

enter image description here

Under Image, click + New and use whatever settings you'd like.

enter image description here

@cegaton says:

Beware: blender does not automatically save the texture in the blend file. The texture has to be saved first by pressing CTRL F3 or using Image Save in the image editor. Otherwise the next time you open the file all of your texturing work will be gone.

Step 3: Setting up the texture painting

Almost done! Go into Texture Paint mode. Press T to make the panel on the left visible. Click on the Slots tab, set the Painting Mode to Image, and select the image you just created.

enter image description here

Now you should be good to go!

Step 4: But it still doesn't work!

-- Make sure you don't have a texture set

Though it's not very clear, the Texture setting does not set the texture it draws on. It sets the texture that the brush uses. Unless you have a specific purpose for using it, it should not be set. If your texture panel looks like this:

enter image description here

That is probably your problem. Click the little X to the right of the F and +.

-- Make sure your settings are configured correctly

These settings may cause you problems:

Drawing mode: You want TexDraw. That should be the default.

Foreground color: If it's the same as the background color of the image, it won't have any effect obviously.

Strength: Make sure it's larger than zero.

Blend: Set it to Mix to make sure it's working. You can mess with it later.

enter image description here

The End

enter image description here

Blender has so many features that a problem like this could be any number of things. If you've followed all the steps and it still didn't work, I'm stumped. If you could upload your .blend file though, we would have a much easier time helping you.

$\endgroup$
  • 3
    $\begingroup$ Beware: blender does not automatically save the texture in the blend file. The texture has to be saved first by pressing CTRL F3 or using Image Save in the image editor. Otherwise the next time you open the file all of your texturing work will be gone. $\endgroup$ – cegaton Dec 9 '14 at 1:56
  • 3
    $\begingroup$ Vertex paint works fine with cycles, you just use an attribute node. $\endgroup$ – PGmath Dec 9 '14 at 2:07
  • $\begingroup$ Thank you for the amazing guide! But I actually found out on my own what the little problem was. I couldn't find the option to set colors and paint to show up in the render, but now I know that it is in the material option on the right panel. $\endgroup$ – Republican31 Dec 10 '14 at 3:34
  • $\begingroup$ YOU ROCK! I never knew that having a texture set under the brush (even if blank) could stop me from painting anything. Makes sense now, though. Thanks! $\endgroup$ – Tyler Mar 21 '18 at 15:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.