4
$\begingroup$

I have a few meshes in which I load into Three.js using the JSONLoader. The problem is, the huge JSON files take up too much memory so I need to reduce the amount of polys in my meshes. Currently, they are sitting at ~84,000, ~103,000, and ~178,200 vertices.

I tried using the Decimate modifer to un-subdivide, but have had no luck as the UVs become ruined, and thus my textures are also ruined. I don't have time to fully retopologize or make a lower poly mesh. I searched and found the poly-reducer script, but it was removed in 2.49. What other options do I have to reduce the poly count and allow my mesh to work with Three.js?

$\endgroup$
  • $\begingroup$ Try decimate planar with delimit UV option enabled $\endgroup$ – Denis Jan 5 '17 at 3:46
7
$\begingroup$

To keep UVs with Decimate Modifier you need to use Planar dissolve and enable UVs in Delimit section of Decimate modifier

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.