2
$\begingroup$

I try to draw a robot arm for teaching, when I rendered the scene with freestyle enabled, I see that some inner line segments are drawn unexpected. See the image shot below: image shot of the rendered output image

I have only two objects which is a box and a cylinder intersected each other. Any one know there is a method to hide the inner line segments? Thanks.

EDIT: what I would like to see is the similar feature from Sketchup. You can see the screen shot below, it can show both the edge and the back edge lines, in different styles.

screen shot of sketchup

Although the lines from my view are all one or several pixels lines in the 2D plane(no 3D projection feature is enabled of the lines), but they can show the structure beautifully, I would like to see similar feature in Blender, so that I can draw some mechanical design, like robot arm for teaching. I think you mentioned wireframe modifier is too complex for this kind of feature. Thanks.

$\endgroup$
5
  • 1
    $\begingroup$ Related - blender.stackexchange.com/questions/48517/… ? $\endgroup$
    – Mr Zak
    Mar 20, 2016 at 9:18
  • $\begingroup$ @MrZak I see this is a bug and it is currently not solved yet. Are there any way I can disable the "freestyle", but set a width of edge value globally for all the edges? I see in the Render's post processing option, there is a check box named "edge", so I can enable this option, but I don't know how to adjust the edge width. $\endgroup$
    – ollydbg23
    Mar 20, 2016 at 14:02
  • $\begingroup$ I'm not quite sure what you intend to do. To change thickness of all freestyle lines change Line thickness value in Freestyle rollout in Render tab. If you'd like to make edges have some thickness without freestyle, i.e. as geometry, you might want consider using Wirefame modifier. $\endgroup$
    – Mr Zak
    Mar 20, 2016 at 14:48
  • $\begingroup$ @MrZak, I have modified my question, and I added a screen shot of sketchup. Thanks. $\endgroup$
    – ollydbg23
    Mar 20, 2016 at 23:07
  • $\begingroup$ I made another question which state my feature request: blender.stackexchange.com/questions/49183/…, I think it is not the same one as this question. $\endgroup$
    – ollydbg23
    Mar 20, 2016 at 23:17

1 Answer 1

1
$\begingroup$

Freestyle does not account for face intersection at the moment. Partially invisible edges due to an intersection with an occluding face may have a wrong line visibility, as seen in the render. This is a known limitation.

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.