3
$\begingroup$

I have a character made up of multiple meshes, namely a body mesh and two eyeball meshes. I am interested in exporting only the visible surface of the character.

When I export to STL or PLY, the interior vertices remain. In other words, the parts of the eyeballs that are inside the body are included in the export. (Labelled 1 in the diagram below.)

An additional complication is that the body mesh has an interior "mouth" component. Again, vertices that are not visible from the outside are included in the export. (Labelled 2 in the diagram below.)

How can I modify the mesh so that only the visible "surface" vertices are exported?

Interior vertices to exclude: portion 1 and portion 2

Gamera / Chinchilla mesh from Big Buck Bunny

(C) Copyright 2008, Blender Foundation / www.bigbuckbunny.org

Shared under CC-BY 3.0

$\endgroup$
  • $\begingroup$ goto add modifiers boolean and select union $\endgroup$ – user20600 Jan 3 '16 at 2:09
2
$\begingroup$

For separate meshes, you should first of all join them in a single object (ctrlJ)

Then, if in that object you have separate "islands" of faces (like eyeballs and body) you can either:

  • join them manually, adding new geometry, or joining existing
  • make (eg) eyeballs intersect body by enlarging or reducing any of them, and then use a boolean modifier with "union" to get a single, "manifold" mesh (check very well normals before using booleans, and to not have negative scale, since that would invert normals effect in the boolean). Needs some practice with simpler object.

  • to remove "interior geometry" I have no other solution then removing it manually, eventually closing open surfaces left inside (there could be some, since the model was thought for a usage (render, animation) for which this was not a problem).

  • anyway, since you're creating stl, I guess you are going to print the object, so, you can surely have some help before exporting by using the "3d print toolbox" addon (included, but not enabled by default) to find and correct problematic shapes. And after export, the print program tipically have some "correction" tool to fix minor problems.

| improve this answer | |
$\endgroup$
  • $\begingroup$ It actually prints fine without any changes. But I'm using a Kinect to register the printed object, and I'm trying to remove the interior points (cause they're "noise" for registration purposes). Sounds like the only solution is returning the modelling phase - not ideal, but it is what it is! $\endgroup$ – david.libremone Oct 15 '15 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.