2
$\begingroup$

I'm trying to apply some simple materials to different parts of a mesh. They don't have textures, just diffuse colour at present. In object mode, they show up in "solid" view, but in "material" view, they just show as solid black (in texture view, the mesh displays as white but shaded). How can I get the materials to show in "material" view?

Thanks.

Solid view, materials are visible:

solid view

Material view, everything is black (bottom half of material panel is visible):

enter image description here

Also, as a related point, when I tab into edit mode, I can only see the bone weights when in "solid" mode (and again, solid black in object mode), so I have no way of viewing the materials at all.

I have a light source, scale isn't negative, I'm not in local view, what have I messed up?

$\endgroup$
  • $\begingroup$ if that doesn't work, go to each object enter edit, go to the materials tab and check shadeless. $\endgroup$ – JOe Jul 31 '18 at 21:47
4
$\begingroup$
  • Make sure your light source diffuse and specular check box options are checked. Later you can adjust more artistically.

enter image description here

  • If needed. Delete all lights and materials and add new ones with no modifications except color. Sometimes through experimenting we click many settings and do not know the click history. Deleting and adding again may restore defaults.
$\endgroup$
  • 2
    $\begingroup$ Thank you, you got me playing around with the lights. Specular and diffuse were checked, so that wasn't it. But what has solved the problem is changing the lamp type. It was an Area lamp. Changing it to any other type, and the material becomes visible; switch it to Area and the model goes solid black. Why would that be though? $\endgroup$ – OliverD May 15 '15 at 20:32
  • 3
    $\begingroup$ Area lamps are about simulating a soft lightsource by using a large grid of point lights or so. Realtime renderers are usually limited to single or low double digit light sources and work with lighting systems designed for point/spot/sun lamps that have a single origin point. My bestguess anyway. $\endgroup$ – StarWeaver May 16 '15 at 4:31
  • 1
    $\begingroup$ Thanks both of you for your answers. I'd upvote them both but my reputation is too low :-( $\endgroup$ – OliverD May 16 '15 at 14:56
  • $\begingroup$ That arrow is just way too fancy. $\endgroup$ – xissburg May 6 at 20:57
0
$\begingroup$

My solution to this problem in Blender 2.79, which interestingly doesn't occur in Blender 2.80, was to turn on Environment Lighting (in World), as pictured.

Environment Lighting

Notably, I could also solve this problem by using any light source other than a Sun. I opted for a Hemi light source, and for some reason that escapes me, a Sun light source produced only a solid black object in Material mode or Render mode.

Environment Lighting option was by far the most convenient solution, but I've noted two solutions which worked for me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.