3
$\begingroup$

I have been having a lot of trouble getting materials to show up, not just in solid view, but at all. I have gone through a large number of versions of this file and thought maybe something got screwed up somewhere along the way, so I deleted all the materials and started rebuilding them. But the problem shows signs of returning, as now one material is visible in solid view, but as I create more they are only visible in material or render view. They are just basic flat colors.

I don't know a lot - I've been switching back and forth between Blender and Cycles Render as I've been building this. Could that be the issue?

$\endgroup$
  • $\begingroup$ In Cycles, the color will not be displayed by default, there is a setting for it under the material slots. They show up in the material tab right? $\endgroup$ – VRM Oct 9 '15 at 16:05
  • $\begingroup$ @NoviceInDisguise Switching to Blender Render didn't help though. I've been trying copying all the objects into a new file, and the problem is disappearing. I'd like to understand it, but this is a quick work-around. I guess something i did introduced a bit of corruption. Yes, i see them in the materials tab. $\endgroup$ – kim holder Oct 9 '15 at 16:08
  • 1
    $\begingroup$ In cycles you have to go to Materials > Settings > and change the Viewport Color $\endgroup$ – VRM Oct 9 '15 at 16:13
  • $\begingroup$ @NoviceInDisguise I checked and it was changed. I guess it does that by default? The behaviour has resolved by itself now. Maybe deleting the previous materials and building new ones did indeed help? Now that it has been saved and reopened? $\endgroup$ – kim holder Oct 9 '15 at 16:17
  • $\begingroup$ Not for me, must be an addon $\endgroup$ – VRM Oct 9 '15 at 16:18
2
$\begingroup$

When you set a material in the Blender Internal render engine, then it automatically sets the viewport color for you, unlike the Cycles render engine which you have to do manually. When you switch from Blender Internal to Cycles, the Viewport Colors remain.

enter image description here

To set it in Cycles, go to Materials > Settings and change the Viewport Color value:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.