I don't know why my material preview and render preview is looking transparent black like this despite that I have applied principled shader.

I made this scene in the morning and it was working just fine, I saved it but now when I opened it, I made no change but I still cannot view the texture and renders.

Please tell me how to fix this. It is a real problem to check if my color is correct. Yeah my solid display mode is fine. I was following this tutorial by the way. Even rendering the image with EEVEE gives the same black result and I can only see the colors when rendering with cycles and my hardware isn't strong enough to do cycles all the time. Please help.

screenshot showing black objects in material preview mode

  • 1
    $\begingroup$ Is it possible the displacement is too strong, and the mesh is turning inside out? $\endgroup$
    – TheLabCat
    Jun 30, 2021 at 18:11
  • 1
    $\begingroup$ Check if you didn't set Alpha input in Principled BSDF to 0. $\endgroup$ Jun 30, 2021 at 21:44
  • $\begingroup$ But then none of the several objects are visible. I am facing this problem only with eevee and not cycles. And the scene was looking perfect yesterday but it is not working today. I want to render it with eevee but now it is not working and i cannot use cycle for the full render. Is that any issue with my hardware? $\endgroup$
    – Manav Garg
    Jul 1, 2021 at 3:04
  • $\begingroup$ I was facing similar issue in V 3.2 I downgraded to v 2.80 and it worked for me. $\endgroup$
    – Suhas Gg
    Jun 18, 2022 at 11:17

1 Answer 1


Considering the information given:

  • it's not hardware issue, because it worked earlier (unless you updated drivers)
  • it's not a material issue, because it works in Cycles, Material Output is set to All, and you don't use Engine specific nodes
  • It's not object settings, because multiple objects have the same problem

One important thing to test is to create a new project and see if the issue remains there. If not, this confirms it's not hardware issue. Additionally, you can open the problematic project, but in the Open Dialog settings disable Load UI:

My best guess so far is that you have Strength of the studiolight set to 0 - increase it:


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .