1
$\begingroup$

I modeled a mesh and gave it materials. But material colors get in the way; I'd like to go on modeling and just seeing a well-contrasted, solid-light object.

enter image description here

I find this setup uncomfortable and I'd like it to be just solid color, for instance:

enter image description here

I know this is the normal, default Blender behaviour; my question is not "Why my materials doesn't show in viewport", but:

Is there a way to get rid of materials showing in viewport when in solid mode, without removing them?

EDIT: I can use matcaps, I'm using BI. Same problem with Cycles. Apparently shading is ok. I'm trying to post the blend...

blend file

EDIT2: Cycles shows the same behavior. This has been tested with an untamed Blender 2.79a just downloaded.

enter image description here

$\endgroup$
  • 2
    $\begingroup$ You can use a matcap? $\endgroup$ – lemon Apr 6 '18 at 17:58
  • 1
    $\begingroup$ What render engine are you using? $\endgroup$ – Ray Mairlot Apr 6 '18 at 18:22
  • $\begingroup$ There isn't this problem in Cycles. Cycles shows default grey color in Solid shading unless you epxlicitly set viewport material options to use another color. $\endgroup$ – Mr Zak Apr 7 '18 at 16:33
0
$\begingroup$

I'm having a bit of difficulty recreating your problem, but it's possible you have a type of viewport shading activated. Check the menu to the right inside your viewport (press 'n' if you don't see it) and look under the 'Shading' option. It should be located just beneath 'Display'. See if you have something like 'Textured Solids' checked. If you don't, an alternate way to address this problem is to apply a matcap, which you will find in shading, as well. Simply click on the picture after you tick the matcap box, and select the material you want.

$\endgroup$
0
$\begingroup$

Actually I found that:

in edit mode, if I set show hidden wireframe, I get this:

enter image description here

In both object and edit mode, only matcaps work (by substituting materials, so little help). So, afaik, unless there's some way to temporarily switch off materials, apparently there's no way.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.