3
$\begingroup$

I am using this Glass material (http://www.blender-materials.com/material/glass-cg001) for this model here.

The thing is, the yellow color of the Diffuse material on the base of the model turns black when rendered:

Error caused by glass What it needs to look like

I have little to no experience in designing materials in Blender Internal. How do I go about fixing this?

$\endgroup$
  • 2
    $\begingroup$ Try to change the yellow material to receive transparent shadows. $\endgroup$ – Denis Apr 18 '15 at 17:48
  • $\begingroup$ that did not work. $\endgroup$ – RobotUnderscore Apr 18 '15 at 18:09
  • $\begingroup$ I just tested that with the material in your link, and it solved the issue with the shadow. $\endgroup$ – Denis Apr 18 '15 at 18:20
  • 1
    $\begingroup$ Try to check it through camera view, viewport shows some black artifacts in different view distance $\endgroup$ – Denis Apr 18 '15 at 18:41
2
$\begingroup$

To enable shadows from objects with transparency you need to enable Receive Transparent in Shadow section in material tab.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.