3
$\begingroup$

Im having an issue with glass rendered where there isn't something IMMEDIATELY behind it - either objects are in distance or there actually isn't anything there. I need it to render CLEAR, meaning whatever is in background even if it is far off, like how this renders actually the transparent background texture default: Alpha channel through glass material instead of background (Cycles)

I just have a normal glass setup, with a mix shader between transparent and glass nodes. Problem is, when I look at my glass where isn't something RIGHT behind it it turns the world color (white), despite that my film is set to Transparent and I dont render the background color:

enter image description here

What can I do to make glass ACTUALLY transparent?

In recent 2.79: enter image description here

$\endgroup$
  • $\begingroup$ Please attach the .blend $\endgroup$ – WhatAMesh Sep 12 '18 at 22:06
  • 1
    $\begingroup$ @WhatAMesh If you going to ask someone to upload a blend file it is important to say where they should upload it. E.g. blend-exchange.giantcowfilms.com $\endgroup$ – Ray Mairlot Sep 13 '18 at 16:48
  • $\begingroup$ @WhatAMesh they're all too big but honestly if I just make a glass cube in a new cycles file I have the same thing. If you have it working differently could you post/explain what you do when making glass? $\endgroup$ – skyguy Sep 13 '18 at 19:26
  • $\begingroup$ Have you tried the 'transparent glass' under film in the render tab? $\endgroup$ – WhatAMesh Sep 13 '18 at 19:38
  • $\begingroup$ Where is that? I just see "Transparent" under Film in the tab with camera icon @WhatAMesh $\endgroup$ – skyguy Sep 13 '18 at 19:57
2
$\begingroup$

Under Render>Film you can check 'Transparent' and afterwards 'Transparent Glass'. It may be possible that you are using a blender version, which doesn't have this option. If you aren't bound to any particular version I suggest downloading a Daily Build from https://builder.blender.org/download/

I tried with MixShader (Transparend BSDF and Glass BSDF) and just Glass BDSF, both of them work for me.

The cubes are actually transparent, but it of course then must take some background here in the stackexchange.

Edit, because question was edited:

  1. Enable 'Transparent'
  2. Enable 'Transparent Glass'
  3. Disable 'Transparent'

This way 'Transparent Glass' is enabled without making the background transparent (Imgur has problems with BSE so direct link: https://imgur.com/a/2TSKsfe)

enter image description here enter image description here enter image description here enter image description here

$\endgroup$
  • $\begingroup$ I didn't know that option was there. Looks like it wasn't in 2.79b but is in 2.79.5 (build from early July). $\endgroup$ – Rich Sedman Sep 13 '18 at 20:41
  • $\begingroup$ Ok, thanks yes I didn't have that version. I checked it, but now 2 problems - 1. see edit, glass is transparent yes but it goes THROUGH the background objects, even though world background is set to a color. 2. Unrelated but why is this new version all pixelated in previewing render mode? Its lower quality.. $\endgroup$ – skyguy Sep 13 '18 at 20:51
  • $\begingroup$ @skyguy I edited the answer, it works for me when I take an environment texture. If you have more problems add a .blend. $\endgroup$ – WhatAMesh Sep 13 '18 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.