0
$\begingroup$

I was following the Donut tutorial and backtracked to do compositing. However, when I try render animation -> the composite is applied on frame 1 but then TAKES OVER for the rest of the render frames.

  1. Frame 1: Donut and composite background
  2. Frame 2-300: Composite background only.

Here's the image snippet of the render animation output. File output where composite takes over animation frames

Apologies, new to blender. Using blender version 3.3.1 Blend file:

$\endgroup$
5
  • $\begingroup$ ok, that's really weird, i just rendered out your animation to frame 5 and it worked: [1]: i.stack.imgur.com/Bgzhj.png but ...you didn't changed the output file and look at the right directory? $\endgroup$
    – Chris
    Oct 26, 2022 at 5:09
  • $\begingroup$ Definitely the right folder, I've re-rendered a few animation sequences to double check render location. BTW, I'm using Cycles to render $\endgroup$
    – Pcoder
    Oct 26, 2022 at 6:31
  • $\begingroup$ Attempted another Render, same result. I have 'Transparent' enabled in my Cycles setting, which sets the Render Layer node to a completely transparent view after an Image render, which indicates Blender is rendering the composite nodes (pink) and a transparent Render Layer over the top after frame 1. Does that sound like expected behaviour? $\endgroup$
    – Pcoder
    Oct 26, 2022 at 6:55
  • $\begingroup$ I've rendered the complete animation, all 300 frames, every rendered frame is composited over the background. $\endgroup$ Oct 26, 2022 at 9:46
  • $\begingroup$ What colour settings do you have? Under Output settings>Output>Colour $\endgroup$
    – Pcoder
    Oct 26, 2022 at 10:04

1 Answer 1

0
$\begingroup$

So I added a View Layer to the project (which is the top right drop down in blender 3.3.1) and this has 'fixed' the problem.

Seems that the Render Layer node was being overwritten each time a frame was rendered, causing some weird affect where the Render Layer node image became transparent from Frame 2.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .