2
$\begingroup$

I'm new to compositing, so I'm unsure how simple this problem may be to solve; apologies in advance. Anyway, here we go.

My scene was too large to render, so I separated it into 3 different Render Layers-

Render layers

The three layers seem to be rendering correctly, lighting and all, as the render progresses; I can see each individual layer as it should be, and have my Alpha Over nodes set up accordingly-

Node Setup

However, the final render saves to my computer as such-

Final Render

Some final notes; I have transparency selected in the render panel, the render also doesn't work if I remove the "File Output" node, and I have it set to GPU render (though it's the same result even if I change to CPU render).

What am I doing wrong!?

$\endgroup$
1
$\begingroup$

You render layers seem fine, What I think is missing is compositing checked in the Post Processing Panel in the Render tab.

Edit you need to have all 3 layers active in order to work, in the scene part of the Layers Panel, only the layer 3 is active. Shif select the other two layers to enable them.

$\endgroup$
0
$\begingroup$

It's your Alpha Over nodes. Blender has the inputs switched so what you would logically think works (Top goes over the Bottom) is actually backwards. Put the background layer into the top and the top layer into the bottom input of the Alpha Over node.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.