0
$\begingroup$

I made a duplicate of a mesh I modelled and moved it along the Y-axis. Now I want the original mesh and the duplicate to line up but no matter what I try i can not get them to line up. It has been driving my crazy. I have tried every single snap mode there is but none of them work. It keeps overshooting so the meshes overlap each other instead. Surely there must be an easy way to do this? I am boggled by the fact that this has prevented me from continuing my work for the past two hours.

The first image shows the vertices selected that I want to move. I press G and then Y to restrict the move to the Y axis. But even if I place my cursor at the bottom vertex before I start moving it doesn't snap correctly. The snap is all over the place.

The second image shows the closest I can get, which is not what I am trying to achive

Thank you in advance for any help!

BLENDER FILE: https://we.tl/t-ul78z0mBVh

enter image description here

enter image description here

$\endgroup$
10
  • $\begingroup$ Do you have the vertices right through the mesh selected before snapping? - The image shows you're not in wireframe or x-ray mode (SHFT-Z or ALT-X) which you'd need to be to select all the vertices. If that isn't it, try disabling snapping on the toolbar, then hover the mouse over the target vertex and G >Y > CTRL > Click. $\endgroup$
    – John Eason
    Jul 8, 2022 at 15:07
  • $\begingroup$ please share your object: blend-exchange.com $\endgroup$
    – moonboots
    Jul 8, 2022 at 15:16
  • $\begingroup$ Yes X-ray is on. I just quickly took these screenshots afterwards to show the problem. G>Y>CTRL>Click yeilds the same result as in my screenshoot. $\endgroup$ Jul 8, 2022 at 15:21
  • $\begingroup$ As @moonboots comments we'll need to see your Blend file in that case because there's something we aren't understanding in your mesh layout. $\endgroup$
    – John Eason
    Jul 8, 2022 at 15:39
  • $\begingroup$ What are your snap settings? $\endgroup$
    – Robin Betts
    Jul 8, 2022 at 16:13

2 Answers 2

1
$\begingroup$

It's really simple. You don't even need to duplicate your mesh.

First, to get your origin in line for the mesh, go here and enable Transform Origins Only:

enter image description here

Then move the origin outside the range of the mesh on the Y-Axis. Then, enable snapping and move the origin on the y-ais to your corner vertex. (your snapping wasn't working since it snaps to the closest vertex) Then add a mirror modifier and set the Axis to Y.

Problem solved!

Edit:

To not do this manually and all, keep one mesh and add an array modifier on it and enable the merge option. You can also enable the merge option on the mirror, and you can also enable clipping, so when you join it, you can move it out again and your problem will be solved.

Edit 2:

The solution to your snapping problem: Move the object outside the range of the mesh on the Y-Axis. Then, enable snapping and move the mesh on the y-ais to your corner vertex. (your snapping wasn't working since it snaps to the closest vertex).

Also, you can always apply the array modifier by using the dropdown menu on the modifier, and then you can easily edit the rest of them and they won't be uniform.

$\endgroup$
7
  • $\begingroup$ Thanks for the suggestion but this is not what I am looking for. The "mirror" in this case is longer so it needs to be merged with another set on the opposite side. This solution fixes the problem on one side but then I have the same problem on the other side, i.e, I cannot get it to join on the other side. $\endgroup$ Jul 8, 2022 at 15:23
  • $\begingroup$ @Anotherfeffe I take it that your mesh is duplicated many times along the Y-Axis? Well, then, just use an array! $\endgroup$ Jul 8, 2022 at 15:24
  • $\begingroup$ @Anotherfeffe Check my edits. $\endgroup$ Jul 8, 2022 at 15:28
  • $\begingroup$ Array doesn't work. It doesn't let you edit the mesh of the arrayed mesh. An array is basically a constant mirror of the original, They are not going to be unique. They just share the basic elements. I thought I would save myself some time by modelling one and then duplicating it. Turns out this was a waste of time lol. I should just do each one individually. $\endgroup$ Jul 8, 2022 at 15:31
  • $\begingroup$ @Anotherfeffe No, just add the array modifier, and apply the modifier using the dropdown on the modifier. Then you can easily edit the rest and make them unique and won't have to duplicate them. $\endgroup$ Jul 8, 2022 at 17:48
0
$\begingroup$

depending on what result you expect, I believe there are multiple ways to "Line-up":

Anyway if you are using Auto-merge option (Edit Mode) in Tools > Auto-merge, make sure the threshold is not too big for the scale of the model not to merge multiple points into one.

  1. (MERGE / NON-MERGE Option) Add mirror modifier with some Empty axis as a mirroring object, and enable "Clipping"

  2. (NON-MERGE Option) Take the desired points and scale towards a 3D Cursor / Active Element - S, Y, 0 + Enter and replicate for the other side

  3. (MERGE OPTION) Delete the Middle faces, select the outer edges and Ctrl + E > Bridge Edge Loops

But in general, scaling towards desired points in Y-axis should do.

$\endgroup$
2
  • $\begingroup$ Thanks for your suggestions but these are not an option. Option 1 fixes the problem but only on one side. You see this duplicate is longer than the original and it means I also have to line it up on the other side. Option 2 ruins the mesh. It looses its original form in the Y-axis. 3. Might work. I will give it a go. I honestly can't believe that such a simple operation is so involved and complicated. It should be as easy as clicking two vertices and getting them to snap. Or dragging the vertices you want to snap to the point you want to snap it. How is this such a big deal? $\endgroup$ Jul 8, 2022 at 15:28
  • $\begingroup$ "It should be as easy as clicking two vertices and getting them to snap. Or dragging the vertices you want to snap to the point you want to snap it. How is this such a big deal?" - Snapping the two point together is simple operation, try enabling Auto-Merge (N > Tool > Options > Auto Merge checkbox) and enable Snap (Magnet Icon, Vertex selection). Let me know if this helps... ;) $\endgroup$
    – Jan Hrodek
    Jul 11, 2022 at 12:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .