2
$\begingroup$

When I add an image texture to my object, I can't see it when I press material preview. The image I'm trying to use to colour it is very bright and colourful, but it just looks black.

screenshot

I've added a video recording so you can see all my steps and tell me if I'm doing anything wrong.

https://drive.google.com/file/d/1y6ggs8o_Q4pZsTZLtvdPAiBaqnkGVBZ-/view?usp=sharing

https://drive.google.com/file/d/1g7myoPiNIv1g0aqXMH6-J-4FLgIzaMXV/view?usp=sharing

$\endgroup$
7
  • $\begingroup$ could you please pack your image (File > External Data > Pack Resources) and share your file? blend-exchange.com $\endgroup$
    – moonboots
    Jul 3 at 16:45
  • $\begingroup$ Hello, just added it now. Thanks for your reply $\endgroup$ Jul 3 at 16:54
  • 2
    $\begingroup$ As Yousuf Chaudhry says it's a problem of unwrap, but your mesh is high-poly, do you really need a high-poly mesh? Also, the way you'll unwrap will determine how the image will be projected on the object, a Smart UV Project unwrap will give unexpected result, unwrapping with seam will give you more control but as I said your mesh is high-poly so it seems complicated... But you have other ways like Project from View etc $\endgroup$
    – moonboots
    Jul 3 at 17:01
  • $\begingroup$ @moonboots isn't the mesh low-poly? $\endgroup$ Jul 3 at 17:04
  • 1
    $\begingroup$ Sure, it all depends on the purpose actually, for 3D print it may be necessary, but for an animated character I don't think it's a good mesh ;) $\endgroup$
    – moonboots
    Jul 3 at 17:20

1 Answer 1

3
$\begingroup$

You haven't shared your file, so it is impossible to know the exact problem.

However, the closest possible to an answer is that the UVs are not unwrapped, so all you can see is a black preview.

To unwrap it, select your model, go to Edit Mode, and select all by pressing A. Then press U > Smart UV Project if you want to do it automatically without adding seams.

If that doesn't work, you can select an Edge Loop by pressing Alt + LMB and press U > Mark Seam. Then, after adding the seams to the appropriate places, select all and press U > Unwrap.

If you don't know UV Unwrapping, I recommend you search up some of the thousands of tutorials on them on YouTube.

$\endgroup$
2
  • $\begingroup$ Thank you, that first step worked $\endgroup$ Jul 3 at 16:56
  • $\begingroup$ @beatrixhaxby If the answer solved your problem, kindly consider accepting it by pressing the checkbox on the top-left. $\endgroup$ Jul 3 at 16:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.