2
$\begingroup$

I made a simple mesh and added bones, as I was practicing keyframing a bone structure. I applied a procedural wood material to the mesh, and applied smart UV projection. After rendering it out, I noticed that when the mesh bends, the material doesn't follow the deformation, choosing instead to remain "upright". Attaching below my .blend and a link to the rendered clip.

enter image description here

enter image description here

enter image description here

What am I doing wrong? Thanks in advance.

Material
enter image description here

Rendered Animation
https://www.youtube.com/watch?v=psGZs0R25iQ

.Blend
https://drive.google.com/file/d/1fAdkggf7pFVdGza_jHum_jYY_oAy6pgb/view?usp=sharing

$\endgroup$
7
  • 1
    $\begingroup$ hello, there's no material in your file, just a Principled BSDF with white color $\endgroup$ – moonboots Apr 11 at 5:29
  • $\begingroup$ ähem...so there IS a material right? :D sorry, couldn't resist. :D :D :D $\endgroup$ – Chris Apr 11 at 5:45
  • $\begingroup$ lol sorry, I uploaded a version of the file before I added the material. Fixed now, thanks for letting me know. $\endgroup$ – irwazr Apr 11 at 5:52
  • $\begingroup$ Please edit your question to show screenshots of your material nodes instead of requiring someone to download and open your .blend. This will make the question more accessible and relevant to others as well as guarding against the .blend perhaps not being available in future. $\endgroup$ – Rich Sedman Apr 11 at 6:48
  • $\begingroup$ Thanks Rich, good suggestion. Edited. $\endgroup$ – irwazr Apr 11 at 7:05
5
$\begingroup$

The problem was that you used object coordinates. Object coordinates always point towards obeject X, Y and Z-axis. To fix this you have to either change it to UV or Generated coordinates which bend with the object.

SET TO GENERATED: enter image description here

SET TO UV: enter image description here

$\endgroup$
4
  • $\begingroup$ +1, of course... but object coordinates align to the object's axes, with all their transforms, not the world.. :D $\endgroup$ – Robin Betts Apr 11 at 7:37
  • $\begingroup$ Thanks for clearing it Robin $\endgroup$ – Maulik Sharma Apr 11 at 16:12
  • $\begingroup$ Thanks so much! Can't believe it was such a simple error! That's what I get for blindly just setting the input into my texture coordinate node! $\endgroup$ – irwazr Apr 12 at 7:37
  • $\begingroup$ Trust me, it has happened to me more times than you can imagine. That's why I always check my texture coordinates when something goes wrong $\endgroup$ – Maulik Sharma Apr 12 at 15:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.