I can't get these texture to bake properly. I made a video showing my steps here:

These are the steps that I performed in the video:

  1. UV Unwrap the surface
  2. Create texture image node for diffuse
  3. Bake with Cycles GPU set to diffuse
  4. Create texture image node for normal
  5. Bake with Cycles GPU set to normal
  6. Create Pincipled BSDF node
  7. Connect diffuse image color to Principled BSDF color
  8. create Normal Map node and connect normal image color to normal map color.
  9. connect normal map to Principled BSDF's normal
  10. Create material output node and connect Principled BSDF to it

This is what the material looks like without the bake:
enter image description here

This is what the material looks like after the bake:
enter image description here

I've also included the blender file and all of the appropriate texture files in an adjacent folder.


1 Answer 1

  1. Refine your UV unwrap to maximize pixels usage of your texture image. I would suggest a top view project from view (bounds) for this model. enter image description here
  2. Increase your bake image size when creating a new image enter image description here
  3. With diffuse bake setting uncheck direct & indirect lighting so it will only bake the color. enter image description here

Hope this helps!

  • $\begingroup$ Awww so close! This definitely works a lot better but I'm still having some issues. First I get this weird effect when I hit unwrap where it doesn't cover the whole UV sheet. Then when the bake finishes, it looks sort of like the ground but weird in color. I'm definitely closer than before though lol. This is the original texture: imgur.com/a/Scqu6IZ and this is the new texture: imgur.com/a/ibZx0x8 $\endgroup$ Commented Nov 13, 2021 at 8:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .