4
$\begingroup$

I have some simple tile like boxes that fall onto a plane. The tile boxes have a rigid body shape of "Box". However even when I think the simulation would be done, the boxes continue to slide off at shallow angle. What attributes in the rigid body physics controls how much an object grips another object. I tried increasing the friction of all the objects to 1 with no effect. Also turned off bounciness and increased damping. But the objects continue to slide until the point that they are all lying flat on the plane. I would think that friction would stop this.

I recreated the scene from scratch and set the friction of all the objects to 1 before running the simulation. Below is the blend file that I created.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Make sure the plane and all the objects have increased friction $\endgroup$ – VRM Mar 7 '15 at 12:47
  • 1
    $\begingroup$ As I said in my question. I've tried increasing the friction of all objects to 1 and that doesn't stop the sliding. $\endgroup$ – deltaray Mar 7 '15 at 12:54
  • 1
    $\begingroup$ @deltaray Did you rebake the animation after changing the friction value? 'Cause it really should work $\endgroup$ – someonewithpc Mar 7 '15 at 13:50
  • $\begingroup$ I've edited my question to include a copy of the blend file after recreating the scene from scratch. $\endgroup$ – deltaray Mar 7 '15 at 15:04
  • $\begingroup$ Is this problem resolved? I am facing similar issues and not sure of how to set the params. $\endgroup$ – desinghkar Aug 14 '15 at 1:44
5
$\begingroup$

You can use Enable Deactivation option and adjusting it's parameters:

enter image description here

It also helps to have the collision objects set as Passive.

What will also increase the simulation accuracy is number of simulation steps:

enter image description here

The more steps the less sliding in the end and the more accurate simulation (this is 5000 steps):

enter image description here


If you don't want to increase steps, you can also Bake the simulation to keyframes with Object > Animation > Bake Action and delete the keyframes in Dope Sheet Editor that you don't want.


You can also keyframe the animation tag on the rigid body to be checked in the start and in the end of simulation:

enter image description here

This will enable you to control the position and bypass simulation when the tag is on. Notice that during simulation the location (in N panel) of bricks doesn't change from starting position. You need to get the end location and rotation from word_matrix in the Console:

bpy.context.active_object.matrix_world.translation
bpy.context.active_object.matrix_world.to_euler()

And you keyframe the starting position and the end position.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.