0
$\begingroup$

In Blender 2.83, I do the following steps:

  • create a plane and a cube. Give 'collision' physics to the plane, 'cloth' physics to the cube.
  • run the animation
  • simply move the plane around by pressing 'G' to make it 'hit' to the cube.

At this point, you can see that the 'cloth' cube responds to your actions interactively.

However, we cannot do this with rigid body. When the plane is either an 'active' rigid body or a 'passive' one, it does not react to the 'active' rigid body cube...

We can easily see that this is working in Blender2.79. But I cannot do it in Blender2.8.

Was this intentionally removed or is there a bug?

In this stack exchange question the same question is also asked: Physics in blender 2.8 - can't interact with objects while simulation is running

Yet there is not a clear answer.

$\endgroup$
1
$\begingroup$

Sounds like a bug, maybe try checking the "animated" checkbox in the physics settings

$\endgroup$
  • $\begingroup$ You are right!! One has to check the 'animated' checkbox in the physics settings for the plane! This makes sense, since the plane is 'active' but freely 'animated' by the user. I can also definetely confirm that in 2.79, it does not matter whether you check the 'animated' checkbox, it just works interactively by default, so I did not know that they changed it to that. Unfortunately I cannot check your answer as accepted one, cuz I am not respected enough yet :))). Thanks a lot! $\endgroup$ – hrkucuk Jun 14 '20 at 7:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.