0
$\begingroup$

enter image description here As you can see in the image, I added the constraint to the child bone and that should prevent it from going below the plane. But it seems that the parent bone overrides the constraint and moving it may put the child bone under the plane. How can I solve this?

$\endgroup$
2
  • $\begingroup$ What behavior do you expect? The ShrinkWrap bone constraint locks the bone to the surface. So the child should push up or rotates its parent? What is the purpose? $\endgroup$
    – Blunder
    Mar 21, 2022 at 1:59
  • $\begingroup$ @Blunder Yes, it should push up, rotate, or at least limit the animation (movements) of its parent so that the child doesn't go below the plane. The purpose is to prevent the feet from going below the ground in case of a character animation or similar applications. $\endgroup$ Mar 21, 2022 at 17:29

1 Answer 1

1
$\begingroup$

There's more than one potential reason for this, but here's what I suspect, because it's probably the most frequent reason. I can't tell you with more certainty than that without a file to look at.

Here, we've got a bone, with a shrinkwrap constraint, but it's not shrinkwrapping:

enter image description here

Why? Look at the other properties viewport, on the bone tab, in the relations subsection. It's grayed out here, because it's uneditable while in pose mode, but this bone has the "connected" property enabled. This basically anchors the head of the bone to the tail of the bone-- the constrained bone cannot shrinkwrap, because it cannot move, and so the constraint does nothing.

How to fix? Enter edit mode, select the constrained bone, and alt p -> disconnnect bone. (Or, uncheck that "connected" box in properties/bone/relations.) Now the bone can leave its parent's tail to shrinkwrap to our plane:

enter image description here

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .